Opened 10 years ago

Closed 10 years ago

Last modified 12 months ago

#4358 closed defect (fixed)

AGI: larry 1 doesn't restart after dying

Reported by: (none) Owned by: sev-
Priority: high Component: Engine: AGI
Keywords: Cc:
Game: Leisure Suit Larry 1

Description

In Leisure Suit Larry 1, when Larry dies because of unsafe sex you get a scene showing how a new Larry is created. After that scene the game should restart but in ScummVM it does not. (At least not in 0.13.1). I attached a save game just before Larry dies. It's from Leisure Suit Larry in the Land of the Lounge Lizards (1.00 1987-06-01 5.25"/3.5"/DOS/English)

Ticket imported from: #2798797. Ticket imported from: bugs/4358.

Attachments (1)

lsl1.002 (3.7 KB ) - added by SF/*anonymous 10 years ago.
Larry1 Savegame

Download all attachments as: .zip

Change History (14)

by SF/*anonymous, 10 years ago

Attachment: lsl1.002 added

Larry1 Savegame

comment:1 by eriktorbjorn, 10 years ago

Another way to reproduce it is simply walking to the right or left from the first room and let yourself get beaten up.

comment:2 by fingolfin, 10 years ago

Summary: larry 1 doesn't restart after dyingSCI: larry 1 doesn't restart after dying

comment:3 by eriktorbjorn, 10 years ago

I just noticed the summary says "SCI: larry 1 doesn't restart after dying". I thought we were talking about the AGI version.

comment:4 by fingolfin, 10 years ago

Summary: SCI: larry 1 doesn't restart after dyingAGI: larry 1 doesn't restart after dying

comment:5 by fingolfin, 10 years ago

My mistake, this is of course the AGI version.

comment:6 by sev-, 10 years ago

The problem is with sound which never stops and has hanging notes.

comment:7 by sev-, 10 years ago

Keywords: script removed
Priority: normalhigh

comment:8 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:9 by SF/buddha_, 10 years ago

Owner: set to SF/buddha_

comment:10 by sev-, 10 years ago

Although the sound is still awful, the bug itself was fixed in SVN.

comment:11 by sev-, 10 years ago

Owner: changed from SF/buddha_ to sev-
Resolution: fixed
Status: newclosed

comment:12 by SF/buddha_, 10 years ago

The hanging note is now fixed in trunk by r43025, in branch-1-0-0 by r43026
(The fix was for bug #2828333: "AGI: KQ1: Greensleeves always plays").

comment:13 by digitall, 12 months ago

Component: Engine: AGI
Game: Leisure Suit Larry 1
Note: See TracTickets for help on using tickets.