Opened 10 years ago

Closed 10 years ago

Last modified 11 months ago

#4348 closed defect (duplicate)

SCUMM FM-TOWNS: Kanji text overwrites

Reported by: (none) Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Out of interest on how Japanese versions of my favorite games look like i tried the *-fm-jp versions of several games. I know these games are hard/expensive to come by and that makes supporting those versions not easy. But still, one thing that may be worth looking into is something I noticed in most of the fm-jp versions. When text is written in places where there are no game graphics, the text does not get cleared a lot of the times. Causing the next line of text to be written over the previous line. I attached an example from Zak McKracken, but most (if not all) -jp games show this symptom. I would be happy to debug/supply more info if needed, i am using the officially released ScummVM 0.13.1

Ticket imported from: #2795789. Ticket imported from: bugs/4348.

Attachments (1)

zak-fm-jp-bug.png (46.6 KB ) - added by SF/*anonymous 10 years ago.
picture showing several lines of text overwritten

Download all attachments as: .zip

Change History (6)

by SF/*anonymous, 10 years ago

Attachment: zak-fm-jp-bug.png added

picture showing several lines of text overwritten

comment:1 by lordhoto, 10 years ago

I guess this is SCUMM engine specific. The FM-Towns games supported by KYRA don't suffer from it (of course in KYRA text is only displayed on top of game graphics).

comment:2 by lordhoto, 10 years ago

Summary: FM-TOWNS: Kanji text overwritesSCUMM FM-TOWNS: Kanji text overwrites

comment:3 by sev-, 10 years ago

Owner: set to sev-
Resolution: duplicate
Status: newclosed

comment:4 by sev-, 10 years ago

This issue is pretty known and is a result of me trying to make it work. I still have plans to finish it some day.

As of this bugreport, closing it as duplicate of ans ancient #1342836

comment:5 by digitall, 11 months ago

Component: Engine: SCUMM
Game: Zak McKracken
Note: See TracTickets for help on using tickets.