Opened 18 years ago

Closed 18 years ago

#434 closed defect (invalid)

Does not start

Reported by: SF/df5jt Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

Here we go

ScummVM 0.2.0 Release Built on Jun 18 2002 03:35:31

Original PC-version of the game, English language on 7 floppies.

First start up with freshly copied files:

*** peter@margaux:/home/games/sam-and-max$ scummvm samnmax
Unable to open configuration file: /home/peter/.scummvmrc.

Detected game 'Sam & Max', version 6.4.2 WARNING: No path was provided. Assuming the data files are in the current directory! Error(0:0:0x0): Cannot find 'samnmax.000'! peter@margaux:/home/games/sam-and-max$

***

Copied samnmax.001 to samnmax.000

(Tried both: simply copy the floppies into game directory AND set up the game under DOS on a FAT partition. Same error.)

***

peter@margaux:/home/games/sam-and-max$ scummvm samnmax Unable to open configuration file: /home/peter/.scummvmrc.

Detected game 'Sam & Max', version 6.4.2 WARNING: No path was provided. Assuming the data files are in the current directory! Error(0:0:0x0): Bad ID %kc! found in directory!!

*** peter@margaux:/home/games/sam-and-max$ ls -la total 10488 drwxr-xr-x 2 peter peter 4096 Aug 24 14:34 . drwxr-xr-x 8 peter peter 4096 Aug 24 14:34 .. -rwxr-xr-x 1 peter peter 23 Aug 24 14:30 disk.id -rwxr-xr-x 1 peter peter 116395 Aug 24 14:22 install.exe -rwxr-xr-x 1 peter peter 4675 Aug 24 14:22 readme.txt -rwxr-xr-x 1 peter peter 1330296 Aug 24 14:32 samnmax.000 -rwxr-xr-x 1 peter peter 1330296 Aug 24 14:23 samnmax.001 -rwxr-xr-x 1 peter peter 1457152 Aug 24 14:25 samnmax.002 -rwxr-xr-x 1 peter peter 1457152 Aug 24 14:26 samnmax.003 -rwxr-xr-x 1 peter peter 1457152 Aug 24 14:27 samnmax.004 -rwxr-xr-x 1 peter peter 1457152 Aug 24 14:28 samnmax.005 -rwxr-xr-x 1 peter peter

1457152 Aug 24 14:30 samnmax.006 -rwxr-xr-x 1 peter peter 608229 Aug 24 14:31 samnmax.007 peter@margaux:/home/games/sam-and-max$

peter@margaux:/home/games/sam-and-max$ cat disk.id SAMNMAX 1.0 Bruno 7

Any ideas? The following games work fine: Monkey Island 2 and Indiana Jones 4.

System:

AMD Athlon 1 Ghz, 512 MB RAM, GeForce 2 MX 400, ECS K7VTA3 motherboard, combined IDE and SCSI. Debian Linux unstable, kernel 2.4.19

Any ideas?

Ticket imported from: #600915. Ticket imported from: bugs/434.

Change History (4)

comment:1 by SF/trinity78, 18 years ago

this is not a bug.

you need to install the game first. what you did is, you simple copied the disks over to your harddisk. of course this will not work, you need to install the files to decompress and create the two big files samnmax.000 and samnmax.001 out of the seven disk files.

run install.exe/setup.exe to install the game, guess you need a windows machine for it.

comment:2 by (none), 18 years ago

Logged In: NO

maybe the game need to extract first... don't know the floppy version but as far as i remember the was an installer on the first disc

comment:3 by SF/ender, 18 years ago

Owner: set to SF/ender
Resolution: invalid
Status: newclosed

comment:4 by SF/ender, 18 years ago

Thats right, the error your getting about .000 is because you copied a compressed file in it's place! So naturally ScummVM thinks it's full of junk... effectivly, it is :)

Run the installer and extract the files that way. I think they are actually just
RAR's, but I might be wrong. In any case, it should install under dosemu.

If you setup the game on a dos partition and get a missing .000 error, then
something is seriously wrong with your copy of sam and max - That file MUST be there.

BTW, in the future you should post questions like this in the Help forum, as it's an installation question, not a bug with ScummVM.

Note: See TracTickets for help on using tickets.