Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4339 closed defect (fixed)

SAMNMAX: Invalid opcode (regression)

Reported by: SF/cinos Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

./scummvm -v
ScummVM 0.14.0svn40562 (May 14 2009 19:03:34)
Features compiled in: Vorbis FLAC MP3 ALSA zLib

Game keeps crashing when I try to use the binocular in the restaurant (magnifier and wires connected).
User picked target 'samnmax-fr' (gameid 'samnmax')...
Looking for a plugin supporting this gameid... SCUMM Engine [all games]
Starting 'Sam & Max Hit the Road'
(66:210:0x8D59): Invalid opcode 'bd' at 8d59!

Language: French
Version of game: PC CD
Platform: Linux 2.6.27 x86
Compiler: GCC 4.2.4

Ticket imported from: #2791846. Ticket imported from: bugs/4339.

Attachments (1)

samnmax-fr.s01 (41.4 KB ) - added by SF/cinos 11 years ago.
Save before the crash occurs

Download all attachments as: .zip

Change History (3)

by SF/cinos, 11 years ago

Attachment: samnmax-fr.s01 added

Save before the crash occurs

comment:1 by Kirben, 11 years ago

This is a regression, caused by recent cleanups of script opcode tables.

Fixed in ScummVM SVN, use the next daily snapshot of ScummVM SVN.

comment:2 by Kirben, 11 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Summary: samnmax: invalid opcodeSAMNMAX: Invalid opcode (regression)
Note: See TracTickets for help on using tickets.