Opened 11 years ago

Closed 10 years ago

Last modified 13 months ago

#4329 closed defect (fixed)

PS2 0.13.1 scummvm.ini file

Reported by: SF/junebug7556 Owned by: sunmax
Priority: normal Component: Port: PS2
Keywords: Cc:
Game:

Description

ScummVM Version: 0.13.1 running on PS2 (Fat and Slim) with FMCB 1.8
Bug Details: ScummVm.ini file. There appears to be an issue with the writing of the configuration options. Upon running ScummVM.elf the first time, the green/black screen is correctly displayed to add games. After adding a game (Sword1) I can play the first 5 minutes. Upon restating the PS2, and running the ScummVM.elf file, the screen displays the 010101 helix, but then restarts to FMCB. I tried this numerous times - but ScummVM will not load. I then entered UlaunchElf and deleted the ScummVM.ini file and ran the scummVM.elf again. This time it loaded successfully. I added another game (Monkey1) and played it briefly. Restarted PS2 and tried to run ScummVM.elf again. Again, did not load and rebooted to FMCB.

I examined the scummvm.ini file and it had become corrupted with foreign text and replacing the square brackets [] for the option entries. As such all entires in the ini file had been corrupted.

Language: N/A
Version: N/A
Platform: PS2 (Fat and Slim)
Bug: Version 0.12.0 did not have this bug.

Ticket imported from: #2787365. Ticket imported from: bugs/4329.

Change History (9)

comment:1 by jvprat, 11 years ago

Owner: set to sunmax

comment:2 by jvprat, 11 years ago

It would be useful if you could attach one of the corrupted scummvm.ini files here for reference.

comment:3 by SF/junebug7556, 11 years ago

How do I add a file, please.

comment:4 by SF/junebug7556, 11 years ago

I have copies of the corrupted ini file - if I cannot attach here - should I create a new bug report and add it there?

comment:5 by SF/damonfeuer, 11 years ago

I too have had this problem on a my old/fat PS2s. The corruption seems to be random - most of the time it will corrupt, but not always.

Tried three different MCs - 8MB Sony, 16MB Datel and a 64MB Chinese, no discernible difference.

Corruption also occured to the INI file on a USB device (i slightly modified the sources)

comment:6 by sev-, 10 years ago

sunmax, any comment?

comment:7 by sunmax, 10 years ago

Resolution: fixed
Status: newclosed

comment:8 by sunmax, 10 years ago

As of 2009-07-12 fixed in branch-0-13-0 and trunk.

Closed.

comment:9 by digitall, 13 months ago

Component: Port: PS2
Note: See TracTickets for help on using tickets.