Opened 10 years ago

Closed 10 years ago

Last modified 12 months ago

#4326 closed defect (fixed)

PS2 0.13.1 Loading Crash

Reported by: SF/damonfeuer Owned by: sunmax
Priority: normal Component: Port: PS2
Keywords: Cc:
Game:

Description

On older style/fat PS2 ScummVm fails to load if no network adapter is inserted (stalls at frozen helix).

I have two older PS2s - one with NA. ScummVM fails to load on one without NA. ScummVM worked in one with NA. ScummVM failed to load after removing NA.

Possible solution might be to compile a mass only version or an external config file to disable looking for NA/HDD.

Ticket imported from: #2786043. Ticket imported from: bugs/4326.

Change History (6)

comment:1 by jvprat, 10 years ago

Owner: set to sunmax

comment:2 by SF/damonfeuer, 10 years ago

Finally got round to compiling a version that doesn't load the network or HDD modules - this has indeed solved the loading problem. ScummVM now loads on either PS2 - with or without the NA.

It seems on an old style PS2 the PS2SMAP.IRX? module gets stuck waiting to initialise an NA rather than saying that none is inserted. (You can tell I'm not a coder :) )

comment:3 by sev-, 10 years ago

What is the status of this item?

comment:4 by sunmax, 10 years ago

Resolution: fixed
Status: newclosed

comment:5 by sunmax, 10 years ago

As of 2009-07-12 fixed in branch-0-13-0 and trunk.

Closed.

comment:6 by digitall, 12 months ago

Component: Port: PS2
Note: See TracTickets for help on using tickets.