Opened 11 years ago

Closed 10 years ago

#4320 closed defect (fixed)

DW: Music won't play on savegame load

Reported by: SF/meddlingmonk Owned by: dreammaster
Priority: high Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

When a saved game is loaded--either after starting ScummVM or loading while playing the game--music will not play until moving to another 'room'. A variation of this happens when reading the book on dragon lairs in first act: music stops playing when leaving the book view; again, music starts playing again when moving to another location. This might be original behavior but if it is I'd call it an original bug.

Ticket imported from: #2782591. Ticket imported from: bugs/4320.

Change History (10)

comment:1 by fingolfin, 11 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by fingolfin, 11 years ago

Status: newpending
Summary: Music won't play on savegame loadDW: Music won't play on savegame load

comment:3 by SF/meddlingmonk, 11 years ago

Status: pendingnew

comment:4 by SF/meddlingmonk, 11 years ago

Platform doesn't seem to matter. Nor does endianness. Nor does music type (midi, digital). And this has been an issue with every svn build I've done with tinsel enabled ever since tinsel has been available. I've only now gotten around to reporting it. Again, I think this might be original behavior but haven't confirmed with DOSBox.

comment:5 by wjp, 11 years ago

In dosbox the music does play after loading a game.

comment:6 by SF/garrythefish, 11 years ago

same thing happens when existing the screensaver ("Hellooo, is anybody hoooome!" with the screen knocking - after a couple of minutes doing nothing). the music should start over again like in the original, but it just stops and plays again when moving to another room.

cheers

comment:7 by sev-, 10 years ago

Owner: set to dreammaster
Priority: normalhigh

comment:8 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:9 by dreammaster, 10 years ago

Please note that this bug fixes a problem in the PlayMidiSequence routine - if it goes into the GF_ENHANCED_AUDIO_SUPPORT sub-block, StopMidi() is called, which reset the fields for 'currentMidi' and 'currentLoop', before calling AudioCD.Play. Thus the fields were zeroed, and savegames were always saved as if no Midi was currently playing

The result of this is that previously saved savegames won't restore Midi, but newly saved savegames will.

comment:10 by dreammaster, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.