Opened 11 years ago

Closed 11 years ago

Last modified 13 months ago

#4317 closed defect (fixed)

GUI: Folders not always selectable with keyboard

Reported by: SF/sanguinehearts Owned by: wjp
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

I noticed an issue with the folder browser in the ScummVM GUI,
I am using an SVN build compiled myself on Windows Vista.
When a folder is named inside these brackets [] you cannot select a folder or jump to an alphabetical listing when pressing a key (a-z,1-0)
This can be reproduced by creating a folder named [test], and then pressing a keyboard letter for one of your known games.
This does not happen if the folder is named (test).

Ticket imported from: #2781883. Ticket imported from: bugs/4317.

Change History (3)

comment:1 by wjp, 11 years ago

Interesting. It seems that this occurs because the list is sorted by using strcasecmp, and the matching for the keyboard selection is done by comparing upper cased characters. All definitions of strcasecmp and stricmp I could find use the lower case form, so I changed the quickselect code to do the same. (r40467)

(Note that '[' is between the lower case and upper case letters, causing the list traversal code to break.)

comment:2 by wjp, 11 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed

comment:3 by digitall, 13 months ago

Component: GUI
Note: See TracTickets for help on using tickets.