Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#4314 closed defect (invalid)

SAM: Charset fail after loading savegame

Reported by: lordhoto Owned by: lordhoto
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

ScummVM trunk r40022. Debian Linux/amd64 with g++ 4.3.3 German DOS CD

When loading the attached savegame in ScummVM, it loads up fine and plays for some moments. After Sam is hit by all three arrorws the debugger appears and shows up: "charset 0 not in room 41 at 7401914+0 in file samnmax.001"

I already copied data from CD again in case it was corrupted, but still the same error. I'm not sure if it's because of the rather moment the savegame was taken, means right in a cutscene, or if the savegame is maybe corrupted, or some bug in the ScummVM code.

Ticket imported from: #2775152. Ticket imported from: bugs/4314.

Attachments (1)

samnmax.s07 (29.4 KB ) - added by lordhoto 12 years ago.
Slot 7 savegame ("Kopf")

Download all attachments as: .zip

Change History (7)

by lordhoto, 12 years ago

Attachment: samnmax.s07 added

Slot 7 savegame ("Kopf")

comment:1 by fingolfin, 12 years ago

I can confirm this issue in both trunk and 0.13.1.

Interestingly, it does *not* crash when I load from the command line using "-x".

comment:2 by sev-, 11 years ago

Priority: normalblocker

comment:3 by sev-, 11 years ago

Raising priority. This is a release-critical bug.

comment:4 by lordhoto, 11 years ago

Just tried loading the save via commandline as Max said. It seems that indeed the sequence is over then, but strangely the scene is changed to the frog rock, with the "Goto Bumpusville" at the sky. That is incorrect too, usually you should be thrown out of bumpusville after that sequence IIRC.

comment:5 by lordhoto, 11 years ago

I'm playing Sam and Max again right now. And I tried saving at the same point with the current trunk (r42626), but it's not longer possible. Neither via the SCUMM menu nor via the GMM. Thus I guess this save is corrupted, so I'm closing this one as invalid.

comment:6 by lordhoto, 11 years ago

Owner: set to lordhoto
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.