Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#427 closed defect (fixed)

ALL: crash when choosing "about" option

Reported by: SF/matt_hargett Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

-start indy3
-press escape until you are in the gym
-press F5
-on the "how may I serve you" menu, choose "options"
-on the options menu, choose "about"

result:
invalid memory is being accessed at gui.cpp line 524.
("ptr[i] = _bgcolor;"). i is 165. it looks like the pointer
aritgmetic involving ptr a few lines up may be too
aggressive ("ptr += 320 + 1;").

Ticket imported from: #599511. Ticket imported from: bugs/427.

Change History (4)

comment:1 by fingolfin, 17 years ago

Summary: crash when choosing "about" optionALL: crash when choosing "about" option

comment:2 by fingolfin, 17 years ago

Nah, the problem is probably that Indy3 uses more
virtual screens than we expect (which is probably also
the cause for some other odd drawing issues in both
old and new GUI).

The overlay technique would fix this, once we
implement it.

comment:3 by fingolfin, 17 years ago

To be precise, the vscreen 0 in Indy3 goes from y = 16 till
y = 16 +128. The "about" dialog was 134 pixel high, which
caused ScummVM to write to invalid memory. I shrunk the
about dialog to 124 pixels, and to start at y=20 (not y=10),
the same size of the load/save dialog -> crash is gone now.

comment:4 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.