Opened 11 years ago

Closed 10 years ago

#4258 closed defect (invalid)

WII/DIG: Game Crashes before entering the Dark Tunnel

Reported by: SF/sparroww Owned by: dhewg
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Details:

ScummVM 0.13.0
Wii Port
The Dig English (CD)

Game crashes right before entering the Dark Tunnel. Please find attached a savegame in the place where you can find the Dark Tunnel (to the left).

Thanks!

Ticket imported from: #2721322. Ticket imported from: bugs/4258.

Attachments (5)

dig.s00 (24.7 KB ) - added by SF/sparroww 11 years ago.
Savegame near the Dark Tunnel
list.txt (5.8 KB ) - added by SF/sparroww 11 years ago.
MOV00001.part1.rar (200.0 KB ) - added by SF/sparroww 11 years ago.
Crash movie (Part 1)
MOV00001.part2.rar (200.0 KB ) - added by SF/sparroww 11 years ago.
Crash movie (Part 2)
MOV00001.part3.rar (172.4 KB ) - added by SF/sparroww 11 years ago.
Crash movie (Part 3)

Download all attachments as: .zip

Change History (20)

by SF/sparroww, 11 years ago

Attachment: dig.s00 added

Savegame near the Dark Tunnel

comment:1 by wjp, 11 years ago

Summary: Game Crashes before entering the Dark TunnelDIG: Game Crashes before entering the Dark Tunnel

comment:2 by wjp, 11 years ago

Summary: DIG: Game Crashes before entering the Dark TunnelWII/DIG: Game Crashes before entering the Dark Tunnel

comment:3 by fingolfin, 11 years ago

Owner: set to dhewg

comment:4 by fingolfin, 11 years ago

Have you tested whether this works on your desktop machine?

comment:5 by SF/sparroww, 11 years ago

Yes, it worked under Win32 and PSP ports (version 0.13.0)

Thanks!

comment:6 by dhewg, 11 years ago

Hm, works for me, on v0.13.0 and trunk. There's a video sequence, and I could enter the command centre after that.
I guess its crashing when opening/loading that video, did you recompress the video files? Please check if the files on the SD card are present/okay.

comment:7 by SF/sparroww, 11 years ago

dhewg, did you test it under Wii's port? As I've mentioned, it works great under Win32 and PSP versions. On windows, I even used the files directly from the SD Card used in the Wii, and nothing weird happened. It still crashes under Wii though.

comment:8 by dhewg, 11 years ago

Yes, of course I tested it with the Wii port ;)
It's hard to say why it doesn't work for you, especially since you have tested exactly those files with other ports.
I can only guess, but maybe libfat (resposible for SD card access) hates your SD card. This hint comes from other Wii homebrew projects:
This formatting tool seems to fix various SD related problems for users: http://panasonic.jp/support/global/cs/sd/download/sd_formatter.html
Can you try that?

comment:9 by SF/sparroww, 11 years ago

Hi dhewg!

Just used the tool you suggested me, it didn't the trick. Same problem (I'm attaching a video).

I'm guessing it's something similar with the problem I'm facing in The Secret of Monkey Island CD-ROM version: if the audio is OGG, I can't pass the first scene. If I convert the OGG files to MP3, everything goes ok.

I'm also attaching a text file which contains a list of files for The Dig game inside the SD Card. If you know what particular media file refers to that crash, please let me know then I can try to convert it to another format (MP3?).

Thanks!

by SF/sparroww, 11 years ago

Attachment: list.txt added

by SF/sparroww, 11 years ago

Attachment: MOV00001.part1.rar added

Crash movie (Part 1)

by SF/sparroww, 11 years ago

Attachment: MOV00001.part2.rar added

Crash movie (Part 2)

by SF/sparroww, 11 years ago

Attachment: MOV00001.part3.rar added

Crash movie (Part 3)

comment:10 by dhewg, 10 years ago

Even with .ogg files, it just works fine for me, - I cannot reproduce this :(
Do you remember which ogg encoder you used?
Just another wild guess: again, multiple fixed went into libfat, did you try a recent snapshot? (http://buildbot.scummvm.org/snapshots/trunk/wii-trunk-latest.tar.bz2)

comment:11 by dhewg, 10 years ago

Can you please check if the encoder you used for those ogg files has written its name and version to the meta flags? You can check that with e.g. winamp.
Also, please try to encode the original files with a recent oggenc, and then try those fresh files with the Wii port.

Thanks!

comment:12 by dhewg, 10 years ago

What is the status of this item?

comment:13 by SF/sparroww, 10 years ago

Hi! Sorry I didn't reply early. I was on vacations. Ok, I couldn't check the ogg meta flags nor convert them to new ogg files using a new encoder. But I did convert it to MP3 and... problem solved! It looks like all my ogg files are encoded in some martian way. Thanks for your time and keep up the great work!

comment:14 by sev-, 10 years ago

Closing as invalid then.

comment:15 by sev-, 10 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.