Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4226 closed defect (invalid)

BASS: End credits loop

Reported by: SF/meddlingmonk Owned by: joostp
Priority: normal Component: Engine: Sky
Keywords: script Cc:
Game: Beneath a Steel Sky

Description

Maybe it's not a script issue but I can't think of what else to call it. The end credits loop intead of coming to an end and ScummVM exiting as they used to many builds ago when I last played BASS.

Ticket imported from: #2686469. Ticket imported from: bugs/4226.

Change History (7)

comment:1 by joostp, 11 years ago

Owner: set to joostp

comment:2 by joostp, 11 years ago

Which system and ScummVM version?

comment:3 by joostp, 11 years ago

I don't know if this is a genuine bug or not. I've just looked at the relevant game script and it appears to loop endlessly, implying that this was intended behaviour.

Do you recall which ScummVM version this used to be different in?

comment:4 by SF/meddlingmonk, 11 years ago

You might be right that it was intended. If the script implies it should loop endlessly then maybe this should just be closed. It's been long enough since I last played BASS that maybe my memory is playing tricks on me. Different games do treat end credits differently. COMI comes to the end of the credits and exits. DOTT comes to the end and sits on the tentacle logo and waits to be manually exited. So I'd say joostp is right about the script and let's leave it there and not bother with it.

comment:5 by joostp, 11 years ago

Resolution: invalid
Status: newclosed

comment:6 by joostp, 11 years ago

Aye. Closing as invalid until someone proves the contrary. :)

comment:7 by joostp, 11 years ago

I just took another look at scripts + original code.

The original game would also loop the credits endlessly, but after the first iteration, any keypress would make the game quit back to DOS.

This was done by checking the value of a script variable (pointer_pen, which only gets set in the end_credits script) in the keyboard handler.

Note: See TracTickets for help on using tickets.