Opened 11 years ago

Closed 10 years ago

#4222 closed defect (fixed)

DW2: Hangs when giving brochure to the beekeeper

Reported by: SF/rdp837 Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld II

Description

When running the English CD version of Discworld II through svn ScummVM (Mar 10 2009) on 64bit Vista the game frequently hangs (well it refuses to accept any input but the music and animation still play) just after the ding noise plays when giving the Clicky Brochure to the beekeeper. I did manage to get the game to play through once in about 9 attempts.
I've attached a saved game from just before the problem.

Ticket imported from: #2680397. Ticket imported from: bugs/4222.

Attachments (2)

dw2-gb.002 (2.4 KB ) - added by SF/rdp837 11 years ago.
Saved game
dw2-gb.006 (2.4 KB ) - added by SF/rdp837 11 years ago.
Doesn't crash

Download all attachments as: .zip

Change History (10)

by SF/rdp837, 11 years ago

Attachment: dw2-gb.002 added

Saved game

comment:1 by fingolfin, 11 years ago

Summary: Beekeeper + BrochureDW2: Hangs when giving brochure to the beekeeper

comment:2 by eriktorbjorn, 11 years ago

I can reproduce this on my 32-bit Linux box. As you say, it doesn't happen every time but so far it's two times out of three.

I'm not familiar enough with the Tinsel engine to even hazard a guess, though.

comment:3 by SF/meddlingmonk, 11 years ago

Ditto Mac OS 10.5.6 with a 32-bit PPC processor...sort of. I played through DW2 three when big endian issues were causing major problems and never ran into this even once. That made me think this is a new problem so I started a new game, ran to Dibbler to get the brochure and back to the garden, saved, and then repeatedly gave the brochure to the beekeeper and never once was there a problem. I did the same thing on my 32-bit Linux machine and same thing: with a brand-new game, no problem. But when I use attached saved game, the problem happens practically every time on both machines.

by SF/rdp837, 11 years ago

Attachment: dw2-gb.006 added

Doesn't crash

comment:4 by SF/rdp837, 11 years ago

As per the meddlingmonk's test I tried to crash using a new game and just getting the brochure and giving it to the bee keeper with all other settings and build the same as in my first post. The game didn't crash in 7 attempts. It seems likely that doing another event before giving the Beekeeper the brochure is a factor in the crash. I'll see if I can cause a crash with the new game.
File Added: dw2-gb.006

comment:5 by sev-, 10 years ago

What is the status of this item?

comment:6 by dreammaster, 10 years ago

I've been able to replicate the problem with the attached savegame. Since it isn't occuring with new savegames, I'm not sure if the bad savegame is the result of a prior bug which is now fixed or not. I'll spend some time comparing execution of the action using both savegames to see if I can at least track down where the difference occurs.

comment:7 by dreammaster, 10 years ago

Owner: set to dreammaster

comment:8 by dreammaster, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.