Opened 11 years ago

Closed 11 years ago

#4205 closed defect (invalid)

MMv2: Keypads

Reported by: SF/argenzul Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Hi.

Whenever I have to open something that requires using the ingame keypad to enter a numeric code, I find that inputting a random number can open everything everytime. Even if I close them and try to open them again.

That gives me unlimited access to Dr. Fred's lab after I get the key to open the "Sekrit Lab" door.

I believe that it has something to do with the method used to bypass the copy protection nuclear door.

By the way, I am playing Maniac Mansion v2 with ScummVm 0.12.0 on Windows Vista.

Ticket imported from: #2645350. Ticket imported from: bugs/4205.

Change History (2)

comment:1 by fingolfin, 11 years ago

Owner: set to fingolfin
Resolution: invalid
Status: newclosed

comment:2 by fingolfin, 11 years ago

This is *not* caused by ScummVM, but rather a well-known problem with the datafiles. Essentially, these data files contain a crack which bypasses the copy protection, but the way it is done leads to the issue you describe.

See also e.g. <https://sourceforge.net/tracker2/index.php?func=detail&aid=770654&group_id=37116&atid=418820>

Note: See TracTickets for help on using tickets.