Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4202 closed defect (fixed)

SIMON2: Cannot load savegame, also in CD DOS?

Reported by: SF/mikeyco Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: script Cc:
Game: Simon the Sorcerer 2

Description

ScummVM 0.12.0 (Aug 29 2008 11:01:26) - Win32 build Simon the Sorcerer 2 (CD/DOS/English)

It's actually the same problem as the one here. http://sourceforge.net/tracker2/index.php?func=detail&aid=1555117&group_id=37116&atid=418820

Based on the kirben's comments, this bug wasn't supposed to exist in the CD version. However, the same thing happened to me after I saved at the dungeon while Simon was still dizzy and closed ScummVM. When I tried to load my savegame, the game won't load (cursor disappears, but animation and music continues). Any ideas?

Ticket imported from: #2642654. Ticket imported from: bugs/4202.

Attachments (3)

simon2.001 (937 bytes ) - added by SF/mikeyco 12 years ago.
Savegame after the bug.
SIMON2.RAR (212.4 KB ) - added by SF/mikeyco 12 years ago.
Script dump.
simon2.002 (934 bytes ) - added by SF/mikeyco 12 years ago.
Savegame before the bug. Replayed through everything. I can reproduce the bug.

Download all attachments as: .zip

Change History (8)

by SF/mikeyco, 12 years ago

Attachment: simon2.001 added

Savegame after the bug.

comment:1 by fingolfin, 12 years ago

Owner: set to Kirben

comment:2 by Kirben, 12 years ago

I'm unable to reproduce the issue, in the English DOS CD version. We have two separate entries for the English DOS version though, so it is possible there is a script difference between the two versions.

Could you please start ScummVM via command line (Command Prompt or MS-DOS Prompt), and redirect the output to a file, ie: scummvm simon2 > simon2.txt

Press 'Ctrl u' to dump all scripts, wait a few minutes and quit ScummVM. Then attached the file (ie simon2.txt) to this bug report.

by SF/mikeyco, 12 years ago

Attachment: SIMON2.RAR added

Script dump.

comment:3 by SF/mikeyco, 12 years ago

Alright. Script dump has been uploaded. The file has been compressed because it's larger than the file size limit for uploads. Also, during the script dump, this message came up at the console: "derefItem: invalid item 28525!"

by SF/mikeyco, 12 years ago

Attachment: simon2.002 added

Savegame before the bug. Replayed through everything. I can reproduce the bug.

comment:4 by Kirben, 12 years ago

The script output for script 12101, shows that script bug occurs in this DOS CD version too. So I altered the work around for that script bug, to apply to all versions of the game.

Use the next snapshot of ScummVM SVN.

comment:5 by Kirben, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.