Opened 11 years ago

Closed 11 years ago

Last modified 13 months ago

#4183 closed defect (fixed)

GUI: Game name overwrites scroll bar

Reported by: Kirben Owned by: SF/tanoku
Priority: high Component: GUI
Keywords: Cc:
Game:

Description

ScummVM 0.14.0svn (Feb 20 2009 20:43:40)
Compiled under mingw with GCC 4.2.1-dw2
Running on Windows XP Media Center 2005 Edition
Using the modern GUI theme

If the name of a game in the launcher, is longer than the maximum displayable width, then the name will be written over the scroll bar, in certain conditions.

To reproduce:
Change the name of a game, to longer than the maximum displayable width
Make sure that game isn't currently selected
Choose 'Edit Game'
Choose 'OK' or 'Cancel'
The name will written on top of the scroll bar.

Ticket imported from: #2619802. Ticket imported from: bugs/4183.

Attachments (1)

screenshot.png (35.6 KB ) - added by Kirben 11 years ago.
Screenshot of the problem

Download all attachments as: .zip

Change History (8)

by Kirben, 11 years ago

Attachment: screenshot.png added

Screenshot of the problem

comment:1 by fingolfin, 11 years ago

Owner: set to SF/tanoku

comment:2 by fingolfin, 11 years ago

Priority: normalhigh

comment:3 by fingolfin, 11 years ago

I can reproduce this.

comment:4 by SF/tanoku, 11 years ago

I haven't been able to consistently reproduce this behaviour under Mac OS X. Check commit #39335 for a possible fix.

comment:5 by SF/tanoku, 11 years ago

Since nobody has whined too much, I'm guessing that commit #39335 did indeed fix the issue. Closing for now.

comment:6 by SF/tanoku, 11 years ago

Resolution: fixed
Status: newclosed

comment:7 by digitall, 13 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.