Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#418 closed defect (worksforme)

MI2/PocketPC: Error displaying load/save box

Reported by: SF/lzandman Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

I noticed a bug in ScummVM for Pocket PC. When you
let Guybrush look into the coffin of Rapp Scallion (where
you see the ashes; room 19) and press the load/save
game button a GUI error occurs. The lower part of the
GUI is replaced by the ScummVM input keyboard
(which is normal behaviour), but the load/save box itself
doesn't show! Because of this you must reboot the
Pocket PC, because there's no way to exit the game or
to continue playing.

I've tried to reproduce this error on the Win32 version of
ScummVM, but it doesn't occur there. ScummVM for
Win32 doesn't respond to the F5 key press, so you
can't get into trouble that way.

Ticket imported from: #596867. Ticket imported from: bugs/418.

Attachments (1)

monkey.s13 (37.1 KB ) - added by SF/lzandman 17 years ago.
Save game F5 bug

Download all attachments as: .zip

Change History (14)

comment:1 by fingolfin, 17 years ago

What version of ScummVM?

comment:2 by fingolfin, 17 years ago

Status: newpending

comment:3 by SF/lzandman, 17 years ago

Game: Monkey Island 1Monkey Island 2
Status: pendingnew

comment:4 by SF/lzandman, 17 years ago

PocketScumm Build 0.2.0 Release(051302)

comment:5 by fingolfin, 17 years ago

What do you mean, the Windows version doesn't
respond to F5 ?!? It should show the save/load dialog
when you press F5. Please try one of the daily builds
for Windows to confirm this.

As for the PocketPC specific part, we need to contact
the PocketPC porter.

comment:6 by fingolfin, 17 years ago

Summary: Error displaying load/save boxMI2/PocketPC: Error displaying load/save box

comment:7 by SF/lzandman, 17 years ago

I've attached a copy of a save game that shows the error. Just
walk to Rap's coffin (all the way to the right) and look at it. In
the following screen (room 19) the F5 key doesn't work in the
Win32 version of ScummVM.

by SF/lzandman, 17 years ago

Attachment: monkey.s13 added

Save game F5 bug

comment:8 by SF/lzandman, 17 years ago

I've just tried it with a new Win32 version: Build 0.2.2 CVS
(2002-08-03) and it displays the exact same behaviour.

comment:9 by SF/arisme, 17 years ago

This problem should be solved in the latest PocketPC build -
problem was that the F5 key isn't always activated (fe
during cut-scenes) but the keyboard was displayed anyway -
can you recheck it with the latest version from
http://arisme.free.fr/PocketScumm/daily ?

this change was made since revision 1.67 of gui.cpp

Revision 1.67 / (view) - annotate - [select for diffs] , Sun
Aug 4 21:52:40 2002 UTC (2 weeks ago) by arisme
Branch: MAIN
Changes since 1.66: +25 -2 lines
Diff to previous 1.66

Better WinCE virtual keyboard management

comment:10 by fingolfin, 17 years ago

Assigning this to arisme - feel free to close this when/if
you are convinced this issue is fixed.

comment:11 by fingolfin, 17 years ago

Owner: set to SF/arisme

comment:12 by SF/ender, 17 years ago

I'm closing this myself, as I can't replicate it on my iPAQ.

comment:13 by SF/ender, 17 years ago

Owner: changed from SF/arisme to SF/ender
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.