Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#4146 closed defect (worksforme)

WINCE: FEEBLE: Game would not load - loadVGAVideoFile:Failed

Reported by: SF/exolonminer Owned by: SF/knakos
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

Pocket PC 2003SE on HP Ipaq hx2750.

Try to load 'The Feeble Files' failes.

SMK are converted to DXA. Sound is MP3.

Logfile states: loadVGAVideoFile: Read failed!

Same Game Folder works fine with Windows build.

Logfiles Attached.

Ticket imported from: #2580993. Ticket imported from: bugs/4146.

Attachments (1)

Logs.zip (23.0 KB ) - added by SF/exolonminer 12 years ago.
Logfiles

Download all attachments as: .zip

Change History (17)

by SF/exolonminer, 12 years ago

Attachment: Logs.zip added

Logfiles

comment:1 by SF/exolonminer, 12 years ago

Additional Information: Tested with release 0.12.0

comment:2 by SF/exolonminer, 12 years ago

Additional Information: German version of Feeble Files (Floyd - Es gibt noch Helden) 4CD Version is used.

comment:3 by fingolfin, 12 years ago

Owner: set to SF/knakos

comment:4 by sev-, 12 years ago

Could you, please, test with a daily ScummVM build?

comment:5 by SF/knakos, 12 years ago

Resolution: worksforme
Status: newpending

comment:6 by SF/knakos, 12 years ago

The game runs fine over here on the pre-release 0.13.0 (in my setup, it requires the extra path being set to the subdirectory containing the videos). It does require a lot of memory, so it could be that. Further I can only test with the english version. I don't know what else to do about this.

Set to pending to allow response to sev.

comment:7 by SF/exolonminer, 12 years ago

I compiled the current trunk and tried with this pre 0.13.0.

I get the following message within stdout and scummvm exits:

The game in '\Storage Card\scummvm-0.13.0-WinCE\Floyd_MP\' seems to be unknown. Please, report the following data to the ScummVM team along with name of the game you tried to add and its version/language/etc.: "disk1", "1dee84e3dfefffe2d914442045f2c1e5", 9 "disk2", "1dee84e3dfefffe2d914442045f2c1e5", 9 "disk3", "1dee84e3dfefffe2d914442045f2c1e5", 9 "disk4", "53e94f2a91cfca0d4a6dd4fe9e5c6240", 9

User picked target 'feeble-win-de' (gameid 'feeble')... Looking for a plugin supporting this gameid... AGOS Starting 'The Feeble Files'

stderr says:

SDL: Version $Rev: 41 $ bootstrapping GAPI device SDL: Device is portrait, OS version 4.21 build 1088 SDL: orientation 0 SDL: GAPI_RealizePalette NOT IMPLEMENTED SDL: Starting video access detection ---> SDL: System 240x320 SDL: Checking for GAPI SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false SDL: <----- Detection finished. Running on GAPI driver at 240x320 (real 240, 320), using ARM accelerated blitter WARNING: Could not find theme 'scummmodern' falling back to builtin! SDL: GAPI_WinPAINT NOT IMPLEMENTED

comment:8 by SF/exolonminer, 12 years ago

Status: pendingnew

comment:9 by SF/knakos, 12 years ago

That's strange. Are you positive that exactly the same files + dir structure is detected and runs ok with the windows port?

Kirben, any possible comments/hints about this? F.ex. the user adding this values into the detector and trying again? Does that make sense?

comment:10 by SF/knakos, 12 years ago

Owner: changed from SF/knakos to Kirben

comment:11 by SF/exolonminer, 12 years ago

Yes, I moved the folder from the storage card to the windows harddisk and tried it with 0.13.0pre (Jan 27 2009) and it is running.

comment:12 by Kirben, 12 years ago

The disk1/disk2/disk3/disk4 files can be deleted, since there aren't actually used by ScummVM.

But this sounds like a detection problem specific to the WinCE port, a conflict been game detection in AGOS and Parallaction game engines. As the disk1/disk2/disk3/disk4 files are part of the Amiga version of Nippon Safes, supported via the Parallaction game engine.

comment:13 by Kirben, 12 years ago

Owner: Kirben removed

comment:14 by SF/exolonminer, 12 years ago

Thanks,

I deleted the disk1/disk2/disk3/disk4 files and rebuild the executeable only with the AGOS engine.

Now "The Feeble Files" are up and running.

I can't say if it is a detection conflict or an memory problem but it is version independend. I tried with the GOG englisch version of Feeble and the v0.12.0 release and it is not working, too.

Nevertheless, the solution with an special AGOS startup executeable is working fine for me.

Regards

Exo

comment:15 by SF/exolonminer, 12 years ago

Status: newclosed

comment:16 by Kirben, 11 years ago

Owner: set to SF/knakos
Note: See TracTickets for help on using tickets.