Opened 11 years ago

Closed 11 years ago

#4141 closed defect

KYRA3: Slight game glitch at Underworld gates

Reported by: SF/bobdevis Owned by: lordhoto
Priority: normal Component: Engine: Kyra
Keywords: original Cc:
Game: Kyrandia 3

Description

Game: Kyrandia3: Malcolm's Revenge (CD version)

Language: English

Tested ScummVM versions the bug occurs:

---------------------------------------

ScummVM 20090201build Ubuntu 64bit

DosBox with the original game

Tested ScummVM version the bug does NOT occur:

----------------------------------------------

None. The bug is in the original game.

Bug overview:

-------------

When you are in Limbo (the fish world), your main goal is to get to the Underworld. There is a man waiting in line at the Underworld gate. You can switch your attitude to NICE and talk to him. He will let you go first in line.

The bug is that he will only let you go first in line ONCE. If you leave the Underworld gate and return, he will not let you go first anymore. He will SAY you can go first, but he will not move.

Because of this you can not complete the game if you asked the man if you could go first, but were not actually ready to leave.

How to quickly reproduce from savegame:

---------------------------------------

-Load the provided savegame kyra3.035 (debug.stuck).

-You can talk to everyone but nothing will happen. You are stuck.

How to reproduce (fast walk through)

----------------------------------

-Be in Limbo.

-Take the ride to the Underworld gate.

-Talk to the clerk behind the desk so you know about the Royal Scenance.

-(you will be called back by your magic neck collar to Limbo)

-Take the ride to the Underworld gate again.

-Talk to the man in line in NICE mode and he will let you go first.

-(you will be called back by your magic neck collar again)

-Take the ride to the Underworld gate again.

-Talk to the man in line in NICE mode and he will SAY he will let you go first. He doesn't move however. Now you are stuck.

How to reproduce (thorough walkthough)

--------------------------------------

-Load the provided savegame kyra3.033 (debug.atfishes).

-You have worms in your inventory. Feed 2 of them to the lower big fish of the fish pyramid.

-Walk offscreen to the top-left.

-Walk offscreen to the left.

-(there is a place you can get in the aqua-duct, it is at the top-left of the screen)

-Get into the aqua-duct.

-Click on the handle next to you.

(you are now at the gates of the Underworld)

-Talk to the female at the desk as long as you can.

(you are recalled to Limbo by the Fish Queen)

-As soon as you have control again, take a coin from your inventory and give it to the fish-man standing next to the Queen.

(you are free from her, for a while and back at the fish pyramid)

-You have worms in your inventory. Feed 2 of them to the big fish.

-Walk offscreen to the top-left.

-Walk offscreen to the left.

-Get into the aqua-duct.

-Click on the handle next to you.

-In your UI you have an attitude meter, set it to NICE.

-Talk to the man in line and he will let you go first.

-Click on the lady at the desk and you are recalled again by the Fish Queen.

-As soon as you have control again, take a coin from your inventory and give it to the fish-man standing next to the Queen.

(you are fee from her and back at the fish pyramid)

-You have worms in your inventory. Feed 2 of them to the big fish.

-Walk offscreen to the top-left.

-Walk offscreen to the left.

-Get into the aqua-duct.

-Click on the handle next to you.

-Make sure your attitude meter is still set it to NICE

-Talk to the man in line and he will SAY that you can go first. He will however not move.

Now you are stuck. You are not recalled to the Queen and you can not go to the Underworld.

How to avoid the bug

--------------------

-Load the provided savegame kyra3.033 (debug.atfishes).

-Take the ride to the Underworld gate.

-Talk to the clerk behind the desk so you know about the Royal Scenance.

-(you will be called back by your magic neck collar to Limbo)

-Now, play tic-tac-toe with the Queen. Make 3 moves and no NOT win.

-When you have made 3 moves, drop a coin from your inventory on the floor.

-Take the paper from your inventory and click on the coin.

(You have summoned the Fish King)

-Walk offscreen to the right.

-Take the ride to the Underworld gate again.

-You can now go first in line and then the lady at the desk will let you in.

(welcome to the Underworld)

I have saved the situation where you CAN enter the Underworld in kyra3.037 (debug.tounderworld).

All savegames are saved with the 20090201 build and seem incompatible with the 0.12 stable.

Good luck fixing this :)

Sorry for my wordiness, but I wanted to be as clear as possible.

Ticket imported from: #2568503. Ticket imported from: bugs/4141.

Attachments (1)

k3bugsaves.zip (46.5 KB ) - added by SF/bobdevis 11 years ago.
A zip of savegames to illustrate the bug

Download all attachments as: .zip

Change History (8)

by SF/bobdevis, 11 years ago

Attachment: k3bugsaves.zip added

A zip of savegames to illustrate the bug

comment:1 by lordhoto, 11 years ago

Seems you are not stuck there actually. After changing Malcolm's mood to "Normal", talk to the man. Then change it back to "Nice". Now you can talk to the man and he'll step back for you. (All done with slot 035 save)

Of course it's a minor glitch in the original, but at least it doesn't render the game being not completable.

comment:2 by lordhoto, 11 years ago

Owner: set to lordhoto
Summary: KYRA3: Stuck at Underworld gatesKYRA3: Slight game glitch at Underworld gates

comment:3 by lordhoto, 11 years ago

This bugreport has been moved to Wiki to relevant Engine/TODO page. When the bug will be resolved, an appropriate message will be posted here and the bugreport link removed from Wiki

comment:4 by lordhoto, 11 years ago

Status: newclosed

comment:5 by SF/bobdevis, 11 years ago

Oh lol thanks. To think I typed all of this up and replayed the game on Dosbox because I was sure this was a complete gamebreaker. Pff....

comment:6 by SF/bobdevis, 11 years ago

Status: closednew

comment:7 by lordhoto, 11 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.