Opened 10 years ago

Closed 10 years ago

Last modified 20 months ago

#4135 closed defect (wontfix)

FOA: speech and subtitles do not match for streets name

Reported by: criezy Owned by: BenCastricum
Priority: normal Component: Engine: SCUMM
Keywords: original Cc:
Game: Indiana Jones 4

Description

In the wits path, after rescuing Trottier from the Nazis in Monte Carlo, Trottier tells Indy the name of the two streets at the intersection of which he threw the stone disk out of the window during the car chase. Then when Indy asked him to repeat it, Trottier writes it down.

There the talk didn't match the subtitles: according to the speach the intersection was between Avenue Victor Hugo and Rue Aubergine, but according to the subtitles it was between Boulevard Guerre des Etoiles and Rue Aubergine. The subtitle match what Trottier wrote and when Indy looks at the note and repeat the name of the roads, the speach is correct. This is only when Trottiers tells it the first time than the names are wrong.

I tried to reproduce it without success. I attached a saved game nonetheless, after Indy has just caused the crash crash and before he speaks to Trottier.

The game is the English DOS CD version.
ScummVM 0.13.0 branch from January 26 compiled by myself and run on MacOS X 10.4 Intel.

Ticket imported from: #2553324. Ticket imported from: bugs/4135.

Attachments (2)

atlantis.s18 (26.4 KB) - added by criezy 10 years ago.
Saved game
SAVEGAME.011 (50.3 KB) - added by criezy 10 years ago.
Saved game for original interpreter

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by criezy

Attachment: atlantis.s18 added

Saved game

comment:1 Changed 10 years ago by criezy

Summary: FOA: speech and subtitle does not matchFOA: speech and subtitles do not match for streets name

comment:2 Changed 10 years ago by eriktorbjorn

To reproduce it with that savegame, I had to open the debug console and type "scumm_vars[282] 229". Valid values for the variable are:

223 - Avenue de la Vache and Rue Bearnaise.
224 - Avenue de la Vache and Rue Framboise.
225 - Avenue Renoir and Rue Bearnaise.
226 - Avenue Renoir and Rue Aubergine.
227 - Boulevard Napoleon and Rue Hollandaise.
228 - Avenue Victor Hugo and Rue Aubergine.
229 - Boulevard des Guerres des Etoiles and Rue Aubergine.
230 - Boulevard des Guerres des Etoiles and Rue Framboise.
231 - Avenue Victor Hugo and Rue Bearnaise.

(232 is invalid)

233 - Avenue Victor Hugo and Rue Hollandaise.
234 - Boulevard Napoleon and Rue Lumiere.
235 - Boulevard des Guerres des Etoiles and Rue Lumiere.
236 - Boulevard Napoleon and Rue Piccard.
237 - Boulevard des Guerres des Etoiles and Rue Piccard.
238 - Avenue Milles Bournes and Rue Piccard.
239 - Avenue Milles Bournes and Rue des Regles du Jeu.
240 - Boulevard Napolean and Rue des Regles du Jeu.
241 - Avenue Descartes and Rue Montgolfier.
242 - Boulevard Descartes and Rue Sans Nom.
243 - Boulevard des Guerres des Etoiles and Rue des Regles du Jeu.
244 - Avenue Milles Bournes and Rue Truffaut.
245 - Boulevard Napolean and Rue Framboise.
246 - Boulevard des Guerres des Etoiles and Rue Truffaut.
247 - Boulevard Napolean and Rue Truffaut.
248 - Boulevard Napolean and Rue Bearnaise.
249 - Avenue Eclair and Rue Truffaut.
250 - Avenue des Briques Jaunes and Rue Truffaut.
251 - Avenue des Trois Bois and Rue Framboise.
252 - Avenue des Trois Bois and Rue Hollandaise.
253 - Avenue Milles Bournes and Rue Voltaire.
254 - Boulevard des Guerres des Etoiles and Rue Voltaire.
255 - Boulevard des Guerres des Etoiles and Rue Montgolfier.
256 - Avenue des Briques Jaunes and Rue Sans Nom.

As far as I can tell, it does play two different sounds for case 228 ("Avenue Victor Hugo and Rue Aubergine.") and 229 ("Boulevard des Guerres des Etoiles and Rue Aubergine.") so chances are that LucasArts messed up and that the bug appears in the original as well. But I have not actually verified that.

comment:3 Changed 10 years ago by sev-

criezy, could you try it in the original?

comment:4 Changed 10 years ago by criezy

I forgot to say in my initial comment that the monster.sou was compressed in ogg (and renamed monster.sog). But I just tried again in ScummVM after recopying the original uncompressed monster.sou from the CD and I reproduced the bug in ScummVM 0.13.1 (as I expected since apparently eriktorbjorn reproduced it as well).

I am now playing the game in DosBox to see if I can trigger the bug there as well. Do you know if there is a similar trick I can use with the original interpreter to force it to use the case where the bug happens (229 in the list below)? Otherwise I will just have to try until this case happens I suppose.

comment:5 Changed 10 years ago by criezy

I played the game with the original interpreter in DosBox and after countless crashes and not getting the correct intersection I decided to look in the save game for the values from the table given by eriktorbjorn and edit that value to 229. When using that edited saved game I reproduced the bug in DosBox.

Changed 10 years ago by criezy

Attachment: SAVEGAME.011 added

Saved game for original interpreter

comment:6 Changed 10 years ago by Kirben

Keywords: original added

comment:7 Changed 10 years ago by fingolfin

Moving this to the Wiki, see http://wiki.scummvm.org/index.php/SCUMM/Bugs

comment:8 Changed 10 years ago by fingolfin

Owner: set to fingolfin
Status: newclosed

comment:9 Changed 20 months ago by BenCastricum

Owner: changed from fingolfin to BenCastricum
Resolution: wontfix

I checked the sound files, and the text "Avenue Victor Hugo and Rue Aubergine." was recorded for case 228 _and_ 229. There's no way to fix this bug without the voice actor for Alain Trottier back then (Doug Lee apparently) recording the correct streetnames.

Note: See TracTickets for help on using tickets.