Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4133 closed defect (fixed)

KYRA2: ScummVM quits after death

Reported by: SF/bobdevis Owned by: lordhoto
Priority: normal Component: Engine: Kyra
Version: Keywords:
Cc: Game: Kyrandia 2

Description

Game: Kyrandia2 CD version Language: English

Tested ScummVM versions the bug occurs: --------------------------------------- 0.14.0svn (Jan 31 2009 04:50:16) Ubuntu Linux 64bit 0.13.0pre (Jan 31 2009 13:37:28) WindowsXP 32bit

Tested ScummVM version the bug does NOT occur: --------------------------------------- 0.12.0 (Aug 29 2008 11:01:26) WindowsXP 32bit

Bug details: ------------ Every time you die, the game will crash when you reload a savegame.

When the animation of the death sequence starts the commandline gives the following message: WARNING: Couldn't find music file: '.ADL'! The game continues fine though, and gives you an option to reload a savegame as it should. If you then chose to load any savegame as offered, the game will crash without any commandline output.

The tested Windows version that does not crash gives the WARNING: Couldn't find music file: '.ADL'! aswel, but doesn't crash.

How to reproduce: ----------------- Start a new game Walk left one screen Walk up 1 screen Walk left 1 screen Walk up 2 screens Walk left 2 screens Save your game Click on the swamp twice (you try to cross the swamp and die) Now try to reload.

Keep up the good work!

Ticket imported from: #2551436. Ticket imported from: bugs/4133.

Change History (3)

comment:1 by lordhoto, 12 years ago

Component: Engine: Kyra
Game: Kyrandia 2
Owner: set to lordhoto
Resolution: fixed
Status: newclosed
Summary: KYRA2: Crash after deathKYRA2: ScummVM quits after death

comment:2 by lordhoto, 12 years ago

Thanks for reporting. Actually it didn't crash, but ScummVM just closed due to some typo in the source code :-).

comment:3 by SF/bobdevis, 12 years ago

I can confirm this bug is gone now in the 20090201 build.

Note: See TracTickets for help on using tickets.