Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4124 closed defect (fixed)

AGI: Restart quits ScummVM

Reported by: SF/buddha_ Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 1

Description

Tried restart (F9) from the game menu in Space Quest I & II and Police Quest I. Restarting simply quits ScummVM (Not going back to the launcher either).

Ticket imported from: #2541237. Ticket imported from: bugs/4124.

Change History (4)

comment:1 by SF/buddha_, 12 years ago

Some more information:

Tried with these game versions (From original collection CDs): - Police Quest I (2.0G 1987-12-03/DOS/English) - Space Quest I (2.2 1987-05-07 5.25"/3.5"/DOS/English) - Space Quest II (2.0F 1989-01-05 3.5"/DOS/English)

And with trunk revision 36111 and branch-0-13-0 revision 36106. Both the trunk and branch-0-13-0 bugged in the same way.

comment:2 by wjp, 12 years ago

There's a FIXME about this in AgiEngine::playGame().

comment:3 by bluegr, 12 years ago

Fixed in the latest SVN version

comment:4 by bluegr, 12 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.