Opened 11 years ago

Closed 10 years ago

#4116 closed defect (fixed)

AGI: Using GMM to load causes graphics glitches

Reported by: SF/zer02 Owned by: sev-
Priority: high Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

if loading saved games from the launsher or the GMM the graphics are distorted.

Ticket imported from: #2537054. Ticket imported from: bugs/4116.

Attachments (1)

scummvm00000.JPG (49.1 KB ) - added by SF/zer02 11 years ago.

Download all attachments as: .zip

Change History (7)

by SF/zer02, 11 years ago

Attachment: scummvm00000.JPG added

comment:1 by SF/zer02, 11 years ago

Summary: Using GMM to load causes graphics glitchesAGI: Using GMM to load causes graphics glitches

comment:2 by bluegr, 11 years ago

I can't reproduce this glitch from the launcher. The only way that I was able to reproduce this was to load a game from the GMM (Global Main Menu) while the game's save/load dialog was left open

comment:3 by fingolfin, 11 years ago

Priority: normalhigh

comment:4 by sev-, 10 years ago

Could you, please, provide this save?

comment:5 by sev-, 10 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:6 by sev-, 10 years ago

Fixed in SVN.

AGI engine has several inner loops, when it should not be allowed to load/save via GMM. Now it is disabled in these situations.

Note: See TracTickets for help on using tickets.