Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4113 closed defect (fixed)

LURE: Crash when fighting the beast in the case

Reported by: criezy Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

The game systematically crash when I try to fight the beast in the case (to get to the dragon), with the following error message: Hotspot 43fh tried to set non-existant Animation Id: 5715h!

This means the game is not completable.

To reproduce: 1) Load attached saved game. 2) Go upward to the next room. 3) Go forward a few step and try to hit the beast with the axe.

This is with the french freeware version from the website download page. Scummvm from 0.13.0 branch from January 21 2009. MacOS X 10.4 (Intel).

I downloaded a second time the game to make sure this was not due to the data file being corrupted on my computer. I also wanted to try with the english version but the saved game from one version are not visible with the other (and this is not a name issue as both version save the game with the same name (e.g. lure.xxx).

Ticket imported from: #2536442. Ticket imported from: bugs/4113.

Attachments (1)

lure.003 (16.0 KB ) - added by criezy 12 years ago.

Download all attachments as: .zip

Change History (6)

by criezy, 12 years ago

Attachment: lure.003 added

comment:1 by criezy, 12 years ago

I just tried with version 0.12.0 with the same result (except that I could land a few blow before getting the crash).

comment:2 by criezy, 12 years ago

I just replayed the game till there with the english version and the bug is not reproducible with that version. You will therefore need to use the french version to reproduce it.

comment:3 by dreammaster, 12 years ago

Thanks for the report. I checked the extract tool and the hard-coded offset for one of the fight animations was wrong in the french version. I've committed a new lure.dat in both the release branch and SVN trunk, so downloading this new version should resovle the error.

comment:4 by dreammaster, 12 years ago

Resolution: fixed
Status: newclosed

comment:5 by Kirben, 12 years ago

Owner: set to dreammaster
Note: See TracTickets for help on using tickets.