Opened 11 years ago

Closed 9 years ago

Last modified 11 months ago

#4093 closed defect (fixed)

GUI: minor artifacts in rounded corners

Reported by: wjp Owned by: sev-
Priority: low Component: GUI
Keywords: Cc:
Game:

Description

There are some miscoloured pixels around the rounded bottom of scrollbars and red buttons in the modern theme. See attached magnified screenshot.

Ticket imported from: #2505686. Ticket imported from: bugs/4093.

Attachments (1)

corners.png (2.4 KB ) - added by wjp 11 years ago.
magnified screenshot

Download all attachments as: .zip

Change History (9)

by wjp, 11 years ago

Attachment: corners.png added

magnified screenshot

comment:1 by wjp, 11 years ago

This is with linux on amd64, by the way.

comment:2 by eriktorbjorn, 11 years ago

I noticed that too yesterday. It only seems to happen if I choose the "Antialiased Renderer (16bpp)", not the "Standard Renderer (16bpp)".

comment:3 by wjp, 11 years ago

In the case of the scrollbar, this is caused by first drawing the inside of the scrollbar solidly, and then afterwards drawing a AA-ed background-coloured border on top of the outside border. Because this last border is partially transparent when it begins to turn, the original solid red shines through.

comment:4 by fingolfin, 10 years ago

Owner: set to SF/tanoku

comment:5 by fingolfin, 10 years ago

What is the status of this item?

comment:6 by sev-, 9 years ago

I made them much less pronounced. It is the best thing which is possible with current implementation and 16-bit surface

comment:7 by sev-, 9 years ago

Owner: changed from SF/tanoku to sev-
Resolution: fixed
Status: newclosed

comment:8 by digitall, 11 months ago

Component: GUI
Note: See TracTickets for help on using tickets.