Opened 11 years ago

Closed 11 years ago

#4086 closed defect (invalid)

DIG: Tomb Tram & Crystal Puzzle bug

Reported by: SF/mb1024 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: The Dig

Description

After activating the fifth crystal (for the tomb tram),
I was only able to ride the tram once. Later when I
pressed the "tram call" button, hero said: "nothing happened", as if the crystal wasn't active yet. Re-solving the crystal puzzle is possible, although buggy (sometimes crystal don't go grey when you expect,
and it doesn't show the tram rolling sequence at the moment you activate the fifth crystal, but only when you click "exit"). But it might or might not make the tram "callable" again. The consequent re-solve of the crystal puzzle shows the tram rolling sequence as the first time, right at the moment the fifth crystal goes blue. But again, it might not help summoning the tram. I
managed to re-solve the puzzle and call the train for the second time, but later failed to achieve that result and got stuck.
I don't believe it's how the game was intended to be, thus filing it as a bug.
This bug is for versions 0.11.1, 0.12 and SVN build.
My system: Fedora release 8 (Werewolf)
Kernel 2.6.23.1-42.fc8 on an x86_64
Playing in fb console, in 640x480 16bit (0x311)
Built ScummVM from sources without any configure
options. Exact versions I mention:
ScummVM 0.11.1 (Jun 27 2008 04:32:01)
ScummVM 0.12.0 (Jan 5 2009 02:18:56)
ScummVM 0.13.0svn (Jan 6 2009 06:29:58)
Features compiled in: Vorbis ALSA zLib
Options: normal2x, aspect ratio correction, full
screen, rest is by default.
Game version: The Dig 1.0 (10/30/95) English

Ticket imported from: #2489542. Ticket imported from: bugs/4086.

Attachments (1)

dig.s18 (38.1 KB ) - added by SF/mb1024 11 years ago.
Tomb train station (crystal are all active)

Download all attachments as: .zip

Change History (6)

comment:1 by fingolfin, 11 years ago

Summary: The Dig Tomb Tram & Crystal Puzzle bugDIG: Tomb Tram & Crystal Puzzle bug

comment:2 by sev-, 11 years ago

We need the saves too

by SF/mb1024, 11 years ago

Attachment: dig.s18 added

Tomb train station (crystal are all active)

comment:3 by eriktorbjorn, 11 years ago

The tram is already there. (It's at the left side of the platform.)

comment:4 by SF/mb1024, 11 years ago

You are right, it was there all the time! Since other trams are normally absent in their stations and you must call them, I assumed this one behaves in the same way. When you walk into the station, you can't see the tram, unless you walk to the far left, so it seems it's not there, and the call button doesn't work. I suppose that's how it was intended by game designers, however stupid it might be. Sorry guys!!! The bug is "off".

comment:5 by Kirben, 11 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.