Opened 11 years ago

Closed 11 years ago

#4085 closed defect (fixed)

DIG: slower animations on 0.12

Reported by: SF/mb1024 Owned by: Kirben
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

It appears all animations are played back slower than should be, which results in speech de-sync (animation goes on for a while after voice stopped talking) and longer pauses between phrases. First I thought it's only speech problem, but then noticed that characters seem to walk around slower as well.
This bug is only for version 0.12 up to SVN build, this bug doesn't manifest in 0.11.1.
My system: Fedora release 8 (Werewolf)
Kernel 2.6.23.1-42.fc8 on an x86_64
Playing in fb console, in 640x480 16bit (0x311)
Built ScummVM from sources without any configure options. Exact versions I mention:
ScummVM 0.11.1 (Jun 27 2008 04:32:01)
ScummVM 0.12.0 (Jan 5 2009 02:18:56)
ScummVM 0.13.0svn (Jan 6 2009 06:29:58)
Features compiled in: Vorbis ALSA zLib
Options: normal2x, aspect ratio correction, full screen, rest is by default.
Game version: The Dig 1.0 (10/30/95) English

Ticket imported from: #2489508. Ticket imported from: bugs/4085.

Change History (12)

comment:1 by fingolfin, 11 years ago

Summary: The Dig slower animations on 0.12DIG: slower animations on 0.12

comment:2 by fingolfin, 11 years ago

Hm, slower actors? Weird, there were no changes at all related to that in the SCUMM engine between 0.11.0 and 0.12.0

What *does* catch many people by surprise (and causes speech and actors to seem "out of sync" resp. "too slow) is that the meaning of "text speed" and "text delay" used to be reversed in SCUMM; we fixed that in 0.12.0, but that means you have to readjust your text speed settings. Try pressing the "+" key to increase subtitle speed / decrease the subtitle delay. Does that have any effect?

comment:3 by SF/mb1024, 11 years ago

I turned on subtitles to check the subtitles speed, and I couldn't reproduce the text lag issue in v 0.12 anymore, only in current SVN build.

After playing with talk speed I figured out that, as you say, the problem is in different speed settings. These are things I found out:
1. The speed setting has different numbering in the start screen (60 is default) and in the in-game options dialog (2 is default in v0.11)
2. In v0.11 even if I don't change the speed, and leave global setting at default 60, it is set to 57 in the game-specific section of conf file
3. If I remove the talkspeed line in conf file from the game-specific section, the setting is being set automatically in SVN build to "6", which seems right (there is a short pause, but maybe it's how it should be). If I keep the line there, the speed is wrong ("2"). The global setting stays at 60 in both cases.

Initially I had conf file for version 0.11, so it probably was wrongly interpreted by the 0.12 and later SVN build, and numbers were not converted, thus the delay issue. What is still a mystery to me is why version 0.12 now works with 0.11-style settings (2 is normal speed).

As for animation speed, it does *seem* slower, but I can't actually measure it and compare. If I'll find a way to record a video clip, I'll be able to tell you exactly. Maybe it's just an illusion caused by slower speaking when the speed is wrong.

Anyway, the issue can be solved by altering the talk speed, but I think it's all rather confusing and works somewhat unstable, maybe someone should take another glance at this for the next version, when there is time.

If you need any more info on this, let me know. It's nice to do something for this great project. And sorry if I'm doing anything wrong, I'm new here :)

comment:4 by SF/mb1024, 11 years ago

Sorry, to clearify:

>> If I keep the line there, the speed is wrong ("2")

I'm talking about old version settings, so I mean the line with "60" or "57" setting. A proper number works correctly, don't get me wrong.

comment:5 by fingolfin, 11 years ago

Priority: normalhigh

comment:6 by fingolfin, 11 years ago

Indeed, this is a really nasty regression, and nobody took care of it in the past months. See also bug #2127407

We should either fix this, or revert the patch that introduced this: #2060517. I.e. reverting its code, and then simply changing the label "subtitle speed" to "subtitle delay" everywhere.

comment:7 by fingolfin, 11 years ago

Also see bug #2251765.

comment:8 by sev-, 11 years ago

Priority: highblocker

comment:9 by sev-, 11 years ago

Raising priority. This is a release-critical bug.

comment:10 by Kirben, 11 years ago

The initial subtitle delay wasn't been set correctly (global talkspeed used), and the talkspeed wasn't been read correctly in COMI either (global setting used again). Try the next daily snapshot of ScummVM SVN.

comment:11 by Kirben, 11 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:12 by Kirben, 11 years ago

The problem was fixed, by reverting the recent talkspeed changes to the SCUMM engine.

Since you used 0.13.0svn you will need to manually correct your talkspeed settings (if they were changed) for any SCUMM games, since the talkspeed setting was changed back to a talk delay value again.

Note: See TracTickets for help on using tickets.