Opened 11 years ago

Closed 11 years ago

Last modified 11 months ago

#4058 closed defect (fixed)

GUI: Theme selection oddities and regressions

Reported by: eriktorbjorn Owned by: lordhoto
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

Current ScummVM SVN

ScummVM registers scummmodern.zip as the default setting for gui_theme, but this doesn't work for me. It seems ScummVM doesn't find the file.

The --gui-theme command-line option is documented as accepting "default", "modern" or "classic". But this doesn't work, probably for the same reason as the default setting doesn't.

I noticed that the gui_theme setting in my .scummvmrc file includes the full path to the selected theme. Doesn't ThemeEngine::loadThemeXML() look in the theme path any more?

Ticket imported from: #2473213. Ticket imported from: bugs/4058.

Change History (6)

comment:1 by fingolfin, 11 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 11 years ago

I am working on this right now. The plan is to change gui_theme to contain the *basename* of the theme dir or zip (right now, it stores the full path into the .ini, we plan to change this). Give me 1-2 days, as I am busy with other stuff, then I hopefully will have managed to cleanup the half done patch I have sitting around here :)

comment:3 by SF/tanoku, 11 years ago

Need a hand, Max? Give me a mail and I'll help you out.

comment:4 by lordhoto, 11 years ago

This should now be working again. The new default value should be "scummmodern". I also changed the --gui-theme command line option description. To list all available themes I introduced --list-themes.

comment:5 by lordhoto, 11 years ago

Owner: changed from fingolfin to lordhoto
Resolution: fixed
Status: newclosed

comment:6 by digitall, 11 months ago

Component: GUI
Note: See TracTickets for help on using tickets.