Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4050 closed defect (fixed)

T7G: Glitch with the cake puzzle in The 7th Guest

Reported by: SF/covox Owned by: spookypeanut
Priority: low Component: Engine: Groovie
Keywords: script Cc:
Game: 7th Guest

Description

Version: ScummVM 0.13.0svn (Dec 22 2008 18:44:15)
Platform: Ubuntu Linux 8.10 Intrepid Ibex

When attempting to complete the cake cutting puzzle in the dining room, attempt the following:

- Select a random slice
- Deselect it
- Select a group of 5 slices (two skulls, two stones, one icing)

Not only will the five slices be removed as per the puzzle, but the other unrelated one that was selected and deselected previously will leave too.

Ticket imported from: #2458322. Ticket imported from: bugs/4050.

Change History (5)

comment:1 by jvprat, 11 years ago

Hi, thanks for reporting.

Can you really reproduce it with any slice on the first step? We knew about this bug, but it looked like it just happened when the first piece was the left-most of the second row starting from the background.

This also happened with the original interpreter, so it looks like a script bug (i.e. hard to fix)

comment:2 by jvprat, 11 years ago

Priority: normallow
Summary: GROOVIE: Glitch with the cake puzzle in The 7th GuestT7G: Glitch with the cake puzzle in The 7th Guest

comment:3 by sev-, 11 years ago

Owner: set to spookypeanut

comment:4 by jvprat, 11 years ago

The issue I mentioned (happening just with that concrete slice) is fixed in SVN rev35520. Please reopen this bug if it can really be reproduced with other slices.

comment:5 by jvprat, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.