Opened 11 years ago

Closed 11 years ago

Last modified 11 months ago

#4049 closed defect (fixed)

GUI: SCUMM games in-game gui crash

Reported by: hkzlab Owned by: SF/tanoku
Priority: high Component: GUI
Keywords: Cc:
Game:

Description

Today i've built ScummVM rev.35479 from svn for my psp.
It builds correctly, but it makes games unplayable:
when i'm playing a scumm game (i have tested "The Secret of Monkey Island" english EGA version, "Indiana Jones and the Last Crusade" English EGA and "Indiana Jones and the fate of Atlantis" English talkie ) and press START to get the in-game options/save/load menu i get a hard lockup of the PSP (except with IJFOA, where i get the debugger console appearing and telling me: "ERROR: Widget (ScummMain.Quit) has y + h > 272 (293) ").
This doesn't let me load or save in any scumm games (i still have to test other non-scumm games).
I don't know when this problem appeared, as this is the first scummvm psp build i've done in six months.

Ticket imported from: #2458134. Ticket imported from: bugs/4049.

Change History (12)

comment:1 by sev-, 11 years ago

Owner: set to joostp

comment:2 by fingolfin, 11 years ago

Summary: [PSP] SCUMM games in-game gui crashPSP: SCUMM games in-game gui crash

comment:3 by joostp, 11 years ago

Assigning to Tanoku since I'm not sure how to best fix this. I get the same error when running ScummVM on PC with the 1x scaler, so it seems like a general problem anyway.

comment:4 by joostp, 11 years ago

Owner: changed from joostp to SF/tanoku
Priority: normalhigh

comment:5 by wjp, 11 years ago

Summary: PSP: SCUMM games in-game gui crashGUI: SCUMM games in-game gui crash

comment:6 by hkzlab, 11 years ago

As of revision 35591 i still get the error or the lockup on my PSP.
I'm writing this because in this revision i saw a code update regarding gui, but that did not fix this problem.

comment:7 by SF/tanoku, 11 years ago

Hello hkz, I'm afraid I'm not able to reproduce the crash on my local machine (not owning a PSP). Could you please tell me in which graphic mode are you running ScummVM? 320x200 (centered), 435x272 (best-fit), 480x272 (full screen) or 262x272 (4:3 centered)?

Also, could you try switching to the other modes to check if the crash still occurs? Thanks in advance!

comment:8 by SF/tanoku, 11 years ago

Hey, here's a small update, check revision 35612 and tell me if anything has been fixed. Cheers.

comment:9 by hkzlab, 11 years ago

Just tested, and it works flawlessly!
no crashes with modern/classic theme, thanks :-)

comment:10 by SF/tanoku, 11 years ago

My pleasure. Thanks to you for reporting!

comment:11 by SF/tanoku, 11 years ago

Resolution: fixed
Status: newclosed

comment:12 by digitall, 11 months ago

Component: GUI
Note: See TracTickets for help on using tickets.