Opened 11 years ago

Closed 10 years ago

#4037 closed defect (fixed)

SQ2: message not displayed, or vanishes too quickly

Reported by: SF/counting_pine Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

In Space Quest 2 (2.0F 1989-01-05 3.5"/DOS/English), on the first playable screen, when you go and stand on the airlock platform and it rotates you inside, just before the screen changes you're supposed to get a message saying: "You are whisked away to the airlock chamber."
This is what happens in the original interpreter. But in ScummVM the message doesn't appear.

Trying the original out in DOSBox, the message can be made to stay for longer by lowering the CPU speed.

I think this might be because it was designed to stay there for as long as it took to load the next screen, which took some time in the original, but ScummVM does it almost instantly.

I'm using ScummVM r35392 on Win32, although I expect it will happen on any previous version with AGI support.
The same thing happens in Sarien, although in NAGI I am able to catch a very brief glipse of it.

Ticket imported from: #2434187. Ticket imported from: bugs/4037.

Attachments (1)

sq2_dosbox.png (3.5 KB ) - added by SF/counting_pine 11 years ago.
The message as seen in DOSBox

Download all attachments as: .zip

Change History (4)

by SF/counting_pine, 11 years ago

Attachment: sq2_dosbox.png added

The message as seen in DOSBox

comment:1 by sev-, 11 years ago

Owner: set to sev-

comment:2 by sev-, 10 years ago

Resolution: fixed
Status: newclosed

comment:3 by sev-, 10 years ago

AGI games relied on the fact that it took time to load new room from the floppies. I added relevant artificial delays and now the message is visible.

Note: See TracTickets for help on using tickets.