Opened 11 years ago

Closed 11 years ago

#4034 closed defect (fixed)

AGOS: Music Looping broken (regression)

Reported by: Kirben Owned by: lordhoto
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

ScummVM 0.13.0svn (Dec 13 2008 16:16:49)
Compiled under mingw with GCC 4.2.1-dw2
Running on Windows XP Media Center 2005 Edition
English DOS CD version of Simon the Sorcerer 1

The music no longer loops in several games using the AGOS engine, when the music driver is set to 'windows'.

An example is the music played during the introduction of Simon the Sorcerer 1, which ends early now. The problem occurs in the CD demo of Simon the Sorcerer 1 too, if you don't have the full version.

This is a recent regression, caused by revision 35174, which was committed by lordhoto.

Ticket imported from: #2423449. Ticket imported from: bugs/4034.

Change History (2)

comment:1 by lordhoto, 11 years ago

Should be fixed in r35335.

comment:2 by lordhoto, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.