Opened 11 years ago

Closed 11 years ago

#4000 closed defect (fixed)

WII: Kyrandia doesn't start

Reported by: (none) Owned by: dhewg
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

Version : 0.12.0 (Wii)
Game : The Legend of Kyrandia, Book One (CD DOS version)

I can add the game in the game list, but when I want to start it, it just freezes the wii with a black screen (I have to power off the wii).

It is working on 0.12 PC version (with the same SD card).

Ticket imported from: #2176672. Ticket imported from: bugs/4000.

Change History (11)

comment:1 by fingolfin, 11 years ago

Owner: set to dhewg
Summary: Kyrandia doesn't start on WiiWII: Kyrandia doesn't start

comment:2 by (none), 11 years ago

If I can give you some debug informations, tell me how to do (I looked for a .log file on my SD card but didn't find). By the way, DOTT and Full Throttle are working with the same configuration.

comment:3 by dhewg, 11 years ago

There is no .log generated, currently you can only read the output with a USBGecko device.

I guess ScummVM isn't crashing, it just takes a long while to load all the data it wants to startup the game. Please try my build i just posted on the wii subforums!

comment:4 by lordhoto, 11 years ago

Any news on this one?

comment:5 by dhewg, 11 years ago

I'm pretty sure this is resolved.
r35675 and r35872 gave huge SD performance increases, especially when listing many files in a directory or opening alot of files (which Kyra does).
It just took a loooong time to startup (tucker was worse, it used to take 10 to 15 minutes). Kyra 1 and 2 work fine and fast for me, but i'd like to get feedback from zaccret if it works for her/him now :)

comment:6 by dhewg, 11 years ago

setting this to "pending"

comment:7 by dhewg, 11 years ago

Status: newpending

comment:8 by (none), 11 years ago

Status: pendingnew

comment:9 by (none), 11 years ago

Sorry for the delay. Actually, I have tried today with a fast SD card and you're right, the game is launching. It takes up
2-3 minutes. I haven't tried yet with SVN builds. I'll try to do early.

comment:10 by (none), 11 years ago

Resolution: fixed
Status: newclosed

comment:11 by (none), 11 years ago

Ok. I've tested with r35894. It now takes a few seconds to launch ! Great !
Bug closed/fixed

Note: See TracTickets for help on using tickets.