Opened 12 years ago

Closed 12 years ago

Last modified 2 years ago

#3998 closed defect (fixed)

GUI: Crash in Debugger

Reported by: SF/mthreepwood Owned by: SF/tanoku
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

When using the debugger in some games, it crashes instantly. I've been able to at least reproduce this in the latest revision with Freddi Fish 1 and 2. However, not with Monkey Island 2. This happens with both the modern and classic themes. (Windows XP)

Here's the GDB backtrace:

#0 0x00bd92a1 in Graphics::drawCharIntern<2> ( ptr=0x510e74e <Address 0x510e74e out of bounds>, pitch=1280, src=0xde3cac, h=2, minX=0, maxX=5, color=0) at graphics/font.cpp:65 #1 0x00a86e9a in Graphics::NewFont::drawChar (this=0xead1e0, dst=0x3256500, chr=68 'D', tx=23, ty=-5, color=0) at graphics/font.cpp:112 #2 0x00a74b77 in GUI::ThemeEngine::drawChar (this=0x46cb450, r=@0x22f568, ch=68 'D', font=0xead1e0, state=kStateEnabled) at gui/ThemeEngine.cpp:904 #3 0x00a7ec0d in GUI::ConsoleDialog::drawLine (this=0x372cc80, line=2, restoreBg=false) at gui/console.cpp:206 #4 0x00a7e979 in GUI::ConsoleDialog::drawDialog (this=0x372cc80) at gui/console.cpp:179 #5 0x00a5726d in GUI::NewGui::redraw (this=0x46cabd8) at gui/newgui.cpp:165 #6 0x00a573d6 in GUI::NewGui::runLoop (this=0x46cabd8) at gui/newgui.cpp:207 #7 0x00a57f7d in GUI::Dialog::runModal (this=0x372cc80) at gui/dialog.cpp:73 #8 0x00a7073a in GUI::Debugger::enter (this=0x3727c38) at gui/debugger.cpp:135 #9 0x00a70667 in GUI::Debugger::onFrame (this=0x3727c38) at gui/debugger.cpp:111 #10 0x0041c5b8 in Scumm::ScummEngine::go (this=0x46cbb68) at engines/scumm/scumm.cpp:1731 #11 0x004089fb in runGame (plugin=0x323b1a0, system=@0x3f30f0, edebuglevels=@0x22fe90) at base/main.cpp:211 #12 0x00408fba in scummvm_main (argc=1, argv=0x32311f0) at base/main.cpp:304 #13 0x004061c5 in SDL_main (argc=1, argv=0x32311f0) at backends/platform/sdl/main.cpp:108 #14 0x0040614c in WinMain () at backends/platform/sdl/main.cpp:45 #15 0x00afa478 in main () at c:/MinGW/bin/../lib/gcc/mingw32/3.4.5/../../../../include/math.h:576

Ticket imported from: #2169419. Ticket imported from: bugs/3998.

Change History (6)

comment:1 by SF/mthreepwood, 12 years ago

Owner: set to SF/tanoku

comment:2 by SF/tanoku, 12 years ago

Can't reproduce in any games, including Freddi 1 and 2 Demo. Mac OS X and Linux. Anybody else getting the crash?

comment:3 by SF/mthreepwood, 12 years ago

The bug does not happen all the time, but on most occasions. Sometimes, it also crashes while closing the console as well.

comment:4 by SF/tanoku, 12 years ago

Still no luck whatsoever. Tried spamming all kind of commands into the console. Can you hook me up on IRC so you can give me some clues?

comment:5 by SF/tanoku, 12 years ago

Resolution: fixed
Status: newclosed

comment:6 by digitall, 2 years ago

Component: GUI
Note: See TracTickets for help on using tickets.