Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3979 closed defect (fixed)

ITE: Game locks up in storm clouds scene

Reported by: eriktorbjorn Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

Current SVN version, and 0.12.0 English Wyrmkeep version of the game

After Rif escapes from the prison cell, and the subsequent maze, there's a scene where he walks into an area with storm clouds. A few seconds into this, ScummVM hangs.

This is a regression that appears to have been caused by commit 30955: Fix for bug #1900254 - "ITE: Glitches when bridging the gorge"

Unfortunately, Inherit the Earth never got any release testing before 0.12.0, so the bug went unnoticed until it was mentioned on the forum today.

Ticket imported from: #2125675. Ticket imported from: bugs/3979.

Attachments (1)

ite.s21 (4.7 KB ) - added by eriktorbjorn 12 years ago.
Savegame from right after escaping the maze

Download all attachments as: .zip

Change History (3)

by eriktorbjorn, 12 years ago

Attachment: ite.s21 added

Savegame from right after escaping the maze

comment:1 by bluegr, 12 years ago

There was a special case for the storm animation, which got removed by mistake in subsequent commits - it matches the original now

Fixed in the latest SVN and in the 0.12.0 branch

comment:2 by bluegr, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.