Opened 11 years ago

Closed 11 years ago

#3966 closed defect (worksforme)

MONKEY: EGA versions does not work with 0.12.0

Reported by: SF/juniper35 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

I recently downloaded the latest scummVM version 0.12.0

and tried to play my Secret of Monkey Island game and it wouldn't work any longer. It is the ENGLISH/DOS/EGA version btw.

It loads to the pirate screen wheel page and I type in the numbers and then an error messsage pops up stating:

ScummVM 0. 12. 0 (Aug 29 2008 11: 01: 26)
Console is ready
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: (90:152:0x1B2) : get ResourceAddress Illegal Glob type String (7) num 1831

I've never had this problem before. I have no idea what's going on. I did type exit but it only turned off the game.

Ticket imported from: #2110917. Ticket imported from: bugs/3966.

Change History (12)

comment:1 by fingolfin, 11 years ago

I can't reproduce this issue with trunk (i.e. with SVN builds). Will try to test it with a 0.12.x build later today.

comment:2 by fingolfin, 11 years ago

Summary: SMI and version 12 error messageMONKEY: EGA versions does not work with 0.12.0

comment:3 by fingolfin, 11 years ago

I can not reproduce the issue with trunk and with the 0.12.x branch. But both were debug builds. So I'll now try to build the actual 0.12.0 release in release mode, to see if that makes a difference.

Juniper: What OS are you using?

comment:4 by SF/juniper35, 11 years ago

My OS is Windows XP Pro.

comment:5 by fingolfin, 11 years ago

Owner: set to Kirben

comment:6 by fingolfin, 11 years ago

It works fine for me even with a 0.12.0 release build -- on Mac OS X. Can you please provide MD5 checksums of your data files?

Kirben, do you happen to have Monkey EGA and can test it on Windows?

comment:7 by Kirben, 11 years ago

Owner: Kirben removed

comment:8 by Kirben, 11 years ago

No, I don't have the EGA version of Monkey Island 1, but the EGA demo still works fine.

comment:9 by fingolfin, 11 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:10 by fingolfin, 11 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newpending

comment:11 by SF/sf-robot, 11 years ago

Status: pendingclosed

comment:12 by SF/sf-robot, 11 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.