Opened 12 years ago

Closed 12 years ago

Last modified 21 months ago

#3956 closed defect (fixed)

ANY - MSVC71 compilation fails due to warnings-as-errors

Reported by: SF/quietust Owned by: bluegr
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

As a result of commit 34447 (which enables "treat warnings as errors" for all projects), Parallaction and Queen no longer compile in MSVC71 (and likely MSVC70 as well).

\scummvm\scummvm\engines\queen\journal.cpp(398) : error C2220: warning treated as error - no object file generated \scummvm\scummvm\engines\queen\journal.cpp(398) : warning C4258: 'p' : definition from the for loop is ignored; the definition from the enclosing scope is used (...)

\scummvm\scummvm\engines\parallaction\gui_br.cpp(234) : error C2220: warning treated as error - no object file generated \scummvm\scummvm\engines\parallaction\gui_br.cpp(234) : warning C4258: 'i' : definition from the for loop is ignored; the definition from the enclosing scope is used (...)

Considering the warnings just report what is probably intended behavior, it would probably be safe to simply ignore that warning rather than try to reorder the code to make it go away.

Ticket imported from: #2101083. Ticket imported from: bugs/3956.

Change History (6)

comment:1 by bluegr, 12 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:2 by bluegr, 12 years ago

Should be fixed in the latest SVN

Closing

comment:3 by SF/quietust, 12 years ago

It would appear that engines/igor/parts/part_22.cpp is also affected (in IgorEngine::PART_22_HELPER_2) - I just hadn't noticed because said file (and its dependencies) hadn't been modified recently.

comment:4 by SF/quietust, 12 years ago

Whoops, meant IgorEngine::PART_22_ACTION_102() there.

comment:5 by bluegr, 12 years ago

Should be fixed as well

comment:6 by digitall, 21 months ago

Component: Port: Win32
Note: See TracTickets for help on using tickets.