Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3947 closed defect (fixed)

ALL: Game path with no trailing backslash fails

Reported by: SF/jaingaurav Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Using svn revision 34397 on Curse of Monkey Island, the resource directory is not added to the file tree unless the game path has a trailing backslash '/'. This has been confirmed on Mac OS X and on Linux and is regression from the 0.12.0 release.

Ticket imported from: #2098279. Ticket imported from: bugs/3947.

Change History (5)

comment:1 by fingolfin, 12 years ago

Thanks for the report. This is due to the ongoing restructuring work we are doing on the whole file / FS code, and will soon be fixed.

comment:2 by fingolfin, 12 years ago

Owner: set to fingolfin
Summary: Game path with no trailing backslash failsALL: Game path with no trailing backslash fails

comment:3 by fingolfin, 12 years ago

I commited a temproary workaround for this issue.

comment:4 by fingolfin, 12 years ago

Resolution: fixed
Status: newclosed

comment:5 by anotherguest, 12 years ago

I think this might be an issue when using subfolders in the main games folder? The patch added an extra '/' after my backslash, which broke the Broken Sword games, dig and Full Throttle. I guess this will be resolved properly eventually. :-)

Note: See TracTickets for help on using tickets.