Opened 11 years ago

Closed 11 years ago

#3918 closed defect (fixed)

LURE: Player hits in fights do not register - regression

Reported by: SF/metafox Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

In Lure of the Temptress (VGA/DOS/English), I seem to have encountered a regression, as the problem did not happen in the August 26, 2008 SVN Win32 build.

When in the fights with the axe, swings that you make that should count as hits are not registered at all. The enemy still blocks at times, but the axe appears to go through the enemy when it should register a hit.

I'm using ScummVM SVN 0.13.0svn August 31, 2008 on Win32 (Win XP).

Ticket imported from: #2086419. Ticket imported from: bugs/3918.

Attachments (1)

lure.001 (21.4 KB ) - added by SF/metafox 11 years ago.
Save game from the room before the first fight

Download all attachments as: .zip

Change History (6)

by SF/metafox, 11 years ago

Attachment: lure.001 added

Save game from the room before the first fight

comment:1 by SF/metafox, 11 years ago

Component: Engine: Lure
Game: Lure of the Temptress

comment:2 by dreammaster, 11 years ago

Owner: set to dreammaster

comment:3 by dreammaster, 11 years ago

I did a bit of experimenting with the fighting, and couldn't find any problems - it seems to work just like the original.. you do need to make sure you keep the mouse button or key held down for the entirety of the attack, or else it will abort the action.

The savegame you attached to this message did have an interesting problem, however - it crashed the Lure engine on loading. Apparently, this was because when the data for Goewin was saved, her current schedule Id was saved as being 0, which is an invalid Id. At this point (from memory), Goewin's schedule should have just been switched over to trying to leave the cave. Even with a hack I added to allow the 0 entry, without the leaving schedule set to her, when you leave the cave she'll keep following you around rather than correctly returning to the apothecary.

You wouldn't happen to have a savegame from slightly earlier, would you? I need to see if this bug is reproducable with creating a savegame in that particular room.

comment:4 by dreammaster, 11 years ago

Bugfix for #2480857 - 'Additionally saved savegames were crashing ScummVM' resolves the secondary problem I noticed with savegame load errors. Note that, unfortunately, savegames where this error has already occurred can't easily be fixed - you'd need to go to an earlier savegame which loads correctly.

comment:5 by dreammaster, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.