Opened 11 years ago

Closed 11 years ago

#3916 closed defect (fixed)

LURE: NPC Character (Minnow) stuck in kitchen doorway

Reported by: SF/metafox Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

In Lure of the Temptress (VGA/DOS/English), I seem to have encountered a bug that prevents me from completing the game.

In the Castle wine cellar, I told Minnow to "go to the kitchen and get the knife". After that, Minnow is stuck at the kitchen doorway and won't move.

I can't get back into the wine cellar, as Minnow won't move out of the way, likewise he won't follow me into the gate room.

When I try to give him a command, Diermont goes behind Minnow in the doorway and just travels back and forth around him without telling him anything.

I'm using ScummVM SVN 0.12.0pre August 26, 2008 on Win32 (Win XP).

Ticket imported from: #2085779. Ticket imported from: bugs/3916.

Attachments (1)

lure.001 (23.2 KB ) - added by SF/metafox 11 years ago.
Save game of Minnow stuck in kitchen doorway

Download all attachments as: .zip

Change History (7)

by SF/metafox, 11 years ago

Attachment: lure.001 added

Save game of Minnow stuck in kitchen doorway

comment:1 by SF/metafox, 11 years ago

Component: Engine: Lure
Game: Lure of the Temptress

comment:2 by SF/metafox, 11 years ago

I apologize for not stating the game name before the description. I tried to change it afterward, but it seems that sourceforge won't allow one to do that.

I wonder if perhaps the reason it got stuck was because the knife in your inventory is called "knife" and the knife in the kitchen is "knife" as well? I'm going to try this in the original interpreter and see if it occurs there as well.

comment:3 by lordhoto, 11 years ago

Owner: set to dreammaster
Summary: NPC Character (Minnow) stuck in kitchen doorwayLURE: NPC Character (Minnow) stuck in kitchen doorway

comment:4 by SF/metafox, 11 years ago

I can't seem to reproduce this with the original interpreter. After playing the Lure in the original interpreter I noted that in the original interpreter the Skorl guard came down with Minnow after I sent Minnow to bring him downstairs. When I played it in ScummVM, and performed the same action, Minnow came alone.

comment:5 by dreammaster, 11 years ago

This bug seems related to the issue with the Skorl not properly following Minnow to the cellar, which is now fixed. Under correct circumstances, after the Skorl follows Minnow to the cellar, drinks the wine, and falls unconscious, Minnow becomes a 'follower' of the player: this means he'll automatically action himself to either wander randomly if in the same room as the player, or move between rooms to go to the same room as the player (if the player changes room). So he can't ever end up with an empty schedule.

comment:6 by dreammaster, 11 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.