Opened 11 years ago

Closed 11 years ago

Last modified 11 months ago

#3911 closed defect (fixed)

WINCE: "ScummVM.ini" is overwritten everytime ScummVM starts

Reported by: SF/lostech Owned by: SF/knakos
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game:

Description

The actual (26th august 2008) build of ScummVM V0.13.0 does overwrite the existing "ScummVM.ini" with default settings everytime ScummVM is started. Therefore it is not possible to configure ScummVM or to add games.

Compiler:
Cygwin/cegcc

Tested on:
PocketPC simulator (WM5 image)
Loox N560

Ticket imported from: #2075491. Ticket imported from: bugs/3911.

Change History (17)

comment:1 by fingolfin, 11 years ago

Owner: set to SF/knakos

comment:2 by fingolfin, 11 years ago

Not sure what yo mean with "actual build", and also note that there is no ScummVM 0.13.0 yet -- so, could you clearify: Are you talking about a trunk build (which will becomes 0.13 or so one day) ?

If so, this is possibly caused by the new config file OSystem API. Kostas?

comment:3 by SF/lostech, 11 years ago

Yes, you´re right. Actual TRUNK build is meant which shows up as 0.13.0 in the "About" dialogue.

comment:4 by SF/knakos, 11 years ago

Yep, I haven't built from trunk since we branched 0.12.0. So yes, this is probably due to the the new config file stuff. Should be straightforward to address (:he said and ended up rewriting the FS API :-)).

I'll get to this shortly.

comment:5 by bluegr, 11 years ago

Just wanted to say that this isn't a WinCE specific issue. It also occurs in the regular Windows build of ScummVM

comment:6 by SF/lostech, 11 years ago

Hmm, I can not affirm that. An actual trunk build of the Windows version does not show up this problem on my side. Did you compile with MSVC or with MinGW/MSYS as I did?

comment:7 by bluegr, 11 years ago

Ah I'm sorry, my mistake

It *does* overwrite scummvm.ini, but *not* with default settings

(and I've compiled it using MSVC, but the compiler shouldn't matter in this case)

comment:8 by fingolfin, 11 years ago

Kostas, did you have a chance to look into this yet? Can you reproduce it?

comment:9 by SF/knakos, 11 years ago

Not yet I'm afraid. But I have hopes for a scummvm session this weekend :-) [hope springs eternal :-)]

comment:10 by fingolfin, 11 years ago

Does this still occur? Kostas, can you do some testing (at least building ScummVM, running it, confirming the issue) ?

P.S.: lostech, FYI, "actual" does *not* mean "current, recent", as you seem to think. In particular, it is a false-friend for the german word "aktuell" (that one confused me a lot).

comment:11 by SF/lostech, 11 years ago

Because of that "actual/recent" issue I had written the initial bug description with a date which which was intended to make it more clear ;-)
Nevertheless I "recently" *g* compiled a build and the bug was still there making the trunk WinCE ScummVM unusuable. So the regular V0.12.0 is still the last WinCE version which can be used.

comment:12 by fingolfin, 11 years ago

Can somebody tell me where ScummVM stores its .ini file on WinCE in general (resp. on the affected device(s) in particular) ?

One guess would be that ScummVM tries to load the .ini file from point A, but stores it in point B. This would explain why it keeps being overwritten with some "default". Maybe there are multiple scummvm.ini files on your system (e.g. one in extrapath, and one in wherever ScummVM write the .ini to) ?

comment:13 by SF/knakos, 11 years ago

This is exactly what I'll be tackling next. scummvm.ini is written in the cwd, the notion of which (cwd) dows not exist on ce. A full path must be given. So iirc the situation is similar with the regular windows port (I remember a conversation with kirben and md5 on the list).

comment:14 by fingolfin, 11 years ago

Aha. Well in that case it should be easy to fix: Decide where the .ini should be stored, then overload OSystem_SDL::openConfigFileForReading and OSystem_SDL::openConfigFileForWriting accordingly. Or alternatively modify their defs in sdl.cpp (though an overload would be cleaner).

comment:15 by SF/knakos, 11 years ago

fixed in commit r35421. thanks for reporting.

comment:16 by SF/knakos, 11 years ago

Resolution: fixed
Status: newclosed

comment:17 by digitall, 11 months ago

Component: Port: WinCE
Note: See TracTickets for help on using tickets.