Opened 18 years ago

Closed 18 years ago

Last modified 18 years ago

#390 closed defect (fixed)

ZAK256: using the bus to airport

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

Built on Aug 5 2002 09:16:31 win You should not be able to reach the cashcard reader inside the bus while you are staning outside and the door is still closed.

Ticket imported from: #591678. Ticket imported from: bugs/390.

Change History (5)

comment:1 by fingolfin, 18 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:2 by fingolfin, 18 years ago

I had to undo my fix, it broke to many things.

The issue is still the same: When clicking on the cashcard reader, ScummVM tries to calculate the distance. To this end, the closest unlocked box (closest to the cashcard reader) is determined. This happens to be exactly the box (and exactly the pixel position!) Zak stands, which results in ScummVM thinking Zak was able to reach it. Not right of course.

comment:3 by fingolfin, 18 years ago

Status: closednew

comment:4 by fingolfin, 18 years ago

OK this should be fixed for real now... I hope.

comment:5 by fingolfin, 18 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.