Opened 18 years ago

Closed 17 years ago

Last modified 8 months ago

#39 closed defect (fixed)

Indy4 crashes late in the game

Reported by: SF/olki Owned by: vincenthamm
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

In Atlantis, the game exits with following error:

Loading room 222
Error(94:206:0x15FE3): Invalid actor 205 in
o5_getActorRoom!
Press a key to quit.

Ticket imported from: #481438. Ticket imported from: bugs/39.

Change History (9)

comment:1 Changed 18 years ago by (none)

Logged In: NO

I just saw this too, when you enter the inner circle from the canal after
having "opened" the door with the machine on the right.

comment:2 Changed 18 years ago by (none)

Logged In: NO

I just saw this too, when you enter the inner circle from the canal after
having "opened" the door with the machine on the right.

comment:3 Changed 18 years ago by SF/jackburton

It could be another bug as the one with the camel in Omar-Al-
Jabbar's house.

comment:4 Changed 18 years ago by SF/strigeus

Owner: set to SF/strigeus

comment:5 Changed 18 years ago by SF/root_42

Confirmed! The german version of Indy 4 crashes also at
the entrance to the innermost circle of Atlantis:

Loading room 222
Error(94:206:0x160C3): Invalid actor 205 in
o5_getActorRoom!
Press a key to quit.

comment:6 Changed 17 years ago by vincenthamm

I've spent some time working on this bug.
The game crash because it is testing a variable that should
contain the number of an actor but for some reasons, it's
complete random :/
If I remember well, it's the global variable number 411.
The bug can come from a script that set var 411.

For now, I made a little walkaround to this bug. It'll be
committed to the cvs with my next update (huge update I
promise you)

comment:7 Changed 17 years ago by vincenthamm

Owner: changed from SF/strigeus to vincenthamm

comment:8 Changed 17 years ago by vincenthamm

Resolution: fixed
Status: newclosed

comment:9 Changed 8 months ago by digitall

Component: Engine: SCUMM
Game: Indiana Jones 4
Note: See TracTickets for help on using tickets.