Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3873 closed defect (fixed)

IHNM: Invisible inventory objects

Reported by: eriktorbjorn Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: I Have No Mouth

Description

Latest 0.12 SVN English version of the game

In the Gorrister chapter, if you tie a sheet to the mooring ring, and then cut it loose again, the sheet is put back in your inventory. However, it no longer has any icon, so it appears as an empty inventory slot.

ScummVM prints the message "WARNING: spriteList.spriteCount <= spriteNumber!" repeatedly.

I was not able to reproduce this in DOSbox.

Ticket imported from: #2057200. Ticket imported from: bugs/3873.

Attachments (1)

ihnm-1.s01 (1.1 KB ) - added by eriktorbjorn 12 years ago.
Save game at the mooring ring

Download all attachments as: .zip

Change History (6)

by eriktorbjorn, 12 years ago

Attachment: ihnm-1.s01 added

Save game at the mooring ring

comment:1 by bluegr, 12 years ago

I am unable to reproduce this issue with the provided save game :(

comment:2 by eriktorbjorn, 12 years ago

That's odd. To clarify, I didn't make a rope out of the sheets (that works for me), I just tied one sheet to the ring and then cut it loose again.

comment:3 by bluegr, 12 years ago

Ah, yes, I never tried to tie a sheet to the ring, instead of a rope. Strange bug, indeed

comment:4 by bluegr, 12 years ago

Fixed in the latest SVN version

Closing

comment:5 by bluegr, 12 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.