Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3865 closed defect (invalid)

COMI: guitar duel not working correctly

Reported by: SF/pi4630 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

SCUMM version: 0.11.1
Game: The Curse Of Monkey Island (Monkey Island 3)
Language: Italian
Game Version: CD-ROM (in order to avoid continuos noisy cd-rom access, I created two isos from the cd-roms and mount them).
Platform Compiler: Linux

During the guitar duel with Edward van Helsing, I don't even have the time to click on a chord: the attempt is aborted as if I had clicked on the wrong chord. The Edward actor asks if I may try again, and I retry, but the error persists. This bug doesn't allow me to complete the game.

Ticket imported from: #2054568. Ticket imported from: bugs/3865.

Attachments (1)

comi-it.s01 (84.1 KB ) - added by SF/pi4630 11 years ago.
Save Game before asking for duel

Download all attachments as: .zip

Change History (11)

by SF/pi4630, 11 years ago

Attachment: comi-it.s01 added

Save Game before asking for duel

comment:1 by fingolfin, 11 years ago

This sounds a lot like bug #1296826, which was not a bug after all; but I can't tell for sure from your description... Make sure you click the chords *before* van Helsing stops playing. Even in the original, you had to do that, at least in some cases.

You also may want too read up here: <https://sourceforge.net/tracker/index.php?func=detail&aid=1296826&group_id=37116&atid=418820>.

comment:2 by fingolfin, 11 years ago

Summary: CMI: guitar duel not working correctlyCOMI: guitar duel not working correctly

comment:3 by fingolfin, 11 years ago

Owner: set to fingolfin
Resolution: invalid
Status: newpending

comment:4 by SF/pi4630, 11 years ago

Status: pendingnew

comment:5 by SF/pi4630, 11 years ago

Sorry, I read bug report #1296826 and confirm I'm talking about the same problem. So please an admin could sign this as duplicate and remove my report or link it to the above one.
Reading #1296826, I can confirm as follows:
- When I played COMI in Win95, I didn't notice this bug. The duel was working fine. I had all the time in the world to play the chord. This is a bug. [1]
- With this bug, I don't have a second to play the chord. Just when I move the mouse, the Edward actor would say I'm out of time.
- As far as I remember, the Edward actor would ask for a retry only when your game character *misses* the right chord and *not* when you extend a certain amount of time

You write:"Make sure you click the chords *before* van Helsing stops playing. Even in the original, you had to do that, at least in some cases."

I cannot confirm that. The Guybrush actor will only play his banjo when van Helsing has stopped playing his (indeed, Guybrush has to repeat van Helsing's tunes).

[1] I still have an old Win95 machine, I could run the game and test it there.

comment:6 by SF/pi4630, 11 years ago

I read that bug #1296826 has been closed, because it is presumed as original game behaviour.

I can't recall such behaviour (I finished the game years ago on Win98), but I will test it on a Win98 machine (without scummvm) and report back. According to the results, the bug must eventually be reopened. I will also attach a savegame from that platform.

comment:7 by SF/pi4630, 11 years ago

In the meantime I'd like to give a more detailed description of the bug (I have tried again with scummvm in Linux):

Edward plays his tune with brief pauses before he touches certain chords. So he plays, briefly stops, and plays a chord (I number them from 1 to 5, the sequence changes of cause). The 'stop' before playing the chord is necessary so the player can realize which chord Guybrush has to play.
When Edward's done, it's the turn of Guybrush. He automatically plays the same tune like Edward did and stops (like Edward): the difference here is that the player has to remember which chord needs to pressed. If the player presses the wrong chord, Edward asks if Guybrush is not up to it and if he wants to try again.

A different look at it is this one. Take in mind that I can only report about the first bout (I think it takes three bouts in total, I'm not sure): the higher the bouts the higher the amount of chords Edward touches. EVH = Edward Van Helsing, GT = Guybrush

EVH: tune - 1st chord - tune - 2nd chord - tune - 3rd chord - tune - 4th chord
GB: tune - player must touch the same 1st chord as EVH - tune - player must touch the same 2nd chord as EVH - tune - player must touch the same 3rd chord as EVH - tune - player must touch the same 4th chord as EVH
As said before, the tunes (melodies) are played automatically. The player has just to touch the correct chord.

Right now I'm going to try it under Win98 and report back.

comment:8 by SF/pi4630, 11 years ago

I confirm this is not a bug. I tested the game in Win98 and it behaves the same. Sorry. I put the status to closed.

comment:9 by SF/pi4630, 11 years ago

Status: newclosed

comment:10 by fingolfin, 11 years ago

No worries, you are not the first who has been fooled by this -- we had 5 or so reports on this over the time, and us devs where fooled by it, too (searching for the cause for a long time till we figured out that it was no bug after all :).

Thanks for your report, and please report any bugs you find, we do appreciate the effort :).

Note: See TracTickets for help on using tickets.