Opened 11 years ago

Closed 11 years ago

Last modified 13 months ago

#3840 closed defect (invalid)

WINCE: plugin build fails recognizing games on WM6.1

Reported by: SF/lostech Owned by: SF/knakos
Priority: normal Component: Port: WinCE
Keywords: detection Cc:
Game:

Description

A plugin build of the SVN version 0.12.0 or 0.13.0 can not recognize games with automatic or manual scan if ScummVM is run on a WM6.1 device.
A static build with identically source and configure options instead was still able to find the games on WM6.1.
On WM5 devices this problem does also not occur when using a plugin build.

For more information see the following forum links:

http://forums.scummvm.org/viewtopic.php?t=57&postdays=0&postorder=asc&start=240

http://forums.scummvm.org/viewtopic.php?t=57&postdays=0&postorder=asc&start=255

Compiler:
MSYS/cegcc

Ticket imported from: #2034170. Ticket imported from: bugs/3840.

Change History (6)

comment:1 by sev-, 11 years ago

Owner: set to SF/knakos

comment:2 by fingolfin, 11 years ago

Kostas, can you confirm this issue?

comment:3 by fingolfin, 11 years ago

What is the status of this item?

comment:4 by SF/knakos, 11 years ago

Resolution: invalid
Status: newclosed

comment:5 by SF/knakos, 11 years ago

Remember that plugin builds are not yet officially supported on ce.

I would not go as far as say that the plugin system does not work in WM6.1. What probably happens is this: The plugin dlls are loaded in alphabetical sort order (notice that tinsel is near the very end). Sometime during startup, the LoadLibrary call fails with an out of memory error, and the rest of the engines are not loaded. So you get the first X engines loaded. If someone could try a plugin build with scummvm.exe, dll and the tinsel dll you'd probably verify this. It'd be nice to have this tested and verified, but until then I'm closing this one.

comment:6 by digitall, 13 months ago

Component: Port: WinCE
Note: See TracTickets for help on using tickets.