Opened 11 years ago

Closed 11 years ago

Last modified 6 years ago

#3837 closed defect (duplicate)

TINSEL: Discworld 1, German (?) CD

Reported by: SF/matheschlumpf Owned by:
Priority: normal Component: Engine: Tinsel
Keywords: detection Cc:
Game: Discworld

Description

Hello,
I looking forward to the tinsel engine! I tried the latest version of scummvm:

ScummVM 0.13.0svn (Jul 28 2008 22:05:11)
Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2 FluidSynth

It reported:

User picked target 'tinsel' (gameid 'tinsel')...
Looking for a plugin supporting this gameid... Tinsel Engine
Starting 'Tinsel engine game'
Your game version appears to be unknown. Please, report the following
data to the ScummVM team along with name of the game you tried to add
and its version/language/etc.:
"dw.gra", "c8808ccd988d603dd35dff42013ae7fd", 781656
"english.smp", "4710bd5cc788df1d517370d43abe1101", 343755891

It was sold as German CD-ROM of "Discworld 1". The speech is English only, texts and subtitles can be choosen between French, German, Italian, and Spanish. It run under DOS only.

Thank you for the excellent work!

Jan

Ticket imported from: #2030682. Ticket imported from: bugs/3837.

Change History (9)

comment:1 by fingolfin, 11 years ago

Hi there,
thanks for your report. There are some hints on multi lingual versions in the source code, but I think we haven't tried one yet... However, the data you report matches exactly some existing detection entry in our code, so I am suprised that it is not detected correctly / does not work out of the box...

Can you provide some extra information, please?
* Do your data files include a file called ENGLISH.TXT ? What about GERMAN.TXT, ITALIAN.TXT etc. ?
* There are no english subtitles, are there?
* Can you actually run the game in ScummVM? If yes, does the options dialog work?

comment:2 by fingolfin, 11 years ago

Owner: set to fingolfin
Summary: Tinsel: Discworld 1, German (?) CDTINSEL: Discworld 1, German (?) CD

comment:3 by fingolfin, 11 years ago

Hi there, just to confirm: Your data files contain exactly four *.txt files, and in particular, no english.txt file?

See also bug #2048383.

comment:4 by SF/matheschlumpf, 11 years ago

Using the current version:

ScummVM 0.13.0svn (Aug 27 2008 20:35:04)

I get the message:

User picked target 'tinsel' (gameid 'tinsel')...
Looking for a plugin supporting this gameid... Tinsel Engine
Starting 'Tinsel engine game'
WARNING: Config 'modern' is NOT usable for themes or not found!
WARNING: falling back to classic style!
Cannot find file english.txt!

Using the patch from bug #2048383 the game starts and is playable!

Just for completeness: there is only English speech:
b9973da5c04aa7407f0efe621406d296 english.smp
and subtitles in:
4ecb36a68cc13136f88f90d5095a2dc3 french.txt
88ef4cc6a5854f5485ed937a2bdc77a6 german.txt
2b45d063d31aeb7e6b0c74eb93257484 italian.txt
ba830b3564fb06eb7ab081158d2da2fc spanish.txt

So if this patch will be in the official version the bug can be closed.

Thanks for the excellent work!

Jan

comment:5 by fingolfin, 11 years ago

No, this patch won't make it into our code, as it doesn't do the right thing :). However, we *will* provide a solution for this eventually.

Closing this as a duplicate of bug #2048383 (which is newer, but contains some more details, hence I am closing this one).

comment:6 by fingolfin, 11 years ago

Resolution: fixed
Status: newclosed

comment:7 by fingolfin, 11 years ago

No, this patch won't make it into our code, as it doesn't do the right thing :). However, we *will* provide a solution for this eventually.

Closing this as a duplicate of bug #2048383 (which is newer, but contains some more details, hence I am closing this one).

comment:8 by fingolfin, 11 years ago

Resolution: fixedduplicate

comment:9 by Strangerke, 6 years ago

Component: --Unset--Engine: Tinsel
Game: Discworld
Owner: fingolfin removed
Note: See TracTickets for help on using tickets.