Opened 11 years ago

Closed 11 years ago

#3823 closed defect (fixed)

MONKEY2: Misplaced Text

Reported by: SF/mthreepwood Owned by: sev-
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Monkey2 DOS English, running 0.12.0svn. Mac OS X 10.4.

When Guybrush talks when first arriving on Phatt Island after choosing the third dialogue option, the bottom line is pushed off to the right cutting off part of a word.

See attached screenshot. In the saved game, just click the third option.

Ticket imported from: #2023727. Ticket imported from: bugs/3823.

Attachments (2)

bug_screenshot.zip (113.5 KB ) - added by SF/mthreepwood 11 years ago.
Screenshot of Issue
monkey2.s02 (32.6 KB ) - added by SF/mthreepwood 11 years ago.
Saved Game

Download all attachments as: .zip

Change History (12)

by SF/mthreepwood, 11 years ago

Attachment: bug_screenshot.zip added

Screenshot of Issue

by SF/mthreepwood, 11 years ago

Attachment: monkey2.s02 added

Saved Game

comment:1 by SF/mthreepwood, 11 years ago

File Added: monkey2.s02

comment:2 by SF/clemty, 11 years ago

I can confirm this behavior (Win32) - can also be replicated by using bootparam 9090 and using the syringe on the voodoo doll, then following lechuck into the next room and choosing the "stretchy strongman" line.

comment:3 by SF/clemty, 11 years ago

Just tried it with 0.11.1 release version, it doesn't occur there so it's a regression since then

comment:4 by sev-, 11 years ago

Since it is a regression in one of the most used games, assigning it a release critical status. Raising priority.

comment:5 by sev-, 11 years ago

Priority: normalblocker

comment:6 by Kirben, 11 years ago

This regression is caused by the _newLineCharacter changes to engines/scumm/charset.cpp by sev in revision 31757.

Those _newLineCharacter changes should be limited to the exact game versions that require it.

comment:7 by Kirben, 11 years ago

Owner: set to sev-

comment:8 by SF/mthreepwood, 11 years ago

Moving the "_newLineCharacter = 0xfe;" from the beginning of loadCJKFont() to under the first if statement fixes it. Not sure if that's correct though.

comment:9 by sev-, 11 years ago

Resolution: fixed
Status: newclosed

comment:10 by sev-, 11 years ago

Fixed in SVN and backported.

Note: See TracTickets for help on using tickets.