Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3814 closed defect (fixed)

FW: crash with Amiga Italian version (photocopy room)

Reported by: SF/glorifindel Owned by: SF/buddha_
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Future Wars

Description

Hi, here's another bug with the Italian Amiga version of Future Wars: when you enter the teleport in the right of the screen after you insert the paper and press the green and red button of the photocopy, ScummVM crash without display any warning.

Ticket imported from: #2019344. Ticket imported from: bugs/3814.

Attachments (1)

fw-amiga-it.1 (2.3 KB ) - added by SF/glorifindel 12 years ago.
Savegame - Photocopy room

Download all attachments as: .zip

Change History (14)

by SF/glorifindel, 12 years ago

Attachment: fw-amiga-it.1 added

Savegame - Photocopy room

comment:1 by SF/buddha_, 12 years ago

Owner: set to SF/buddha_

comment:2 by SF/buddha_, 12 years ago

I can't reproduce this bug with my setup.

I went near the black opening in the photocopier's side (apertura), used the bundle of papers on it, then pressed the green button, then the red button, then took the documents from the floor that came out of the photocopier and walked into the light on the right. I got teleported to the swamp without a crash. I ran the game using the Italian Amiga version of Future Wars under MSVC8 in debug mode using the provided savegame (fw-amiga-it.1). My compiled version of ScummVM was using revision 33084 of the trunk.

Some translations for help:

Actions: * take = prendere * use = utilizzare * operate = azionare

Inventory items: * pacco di carta = bundle of papers

comment:3 by SF/buddha_, 12 years ago

Clarification about the severity level of this bug:

This bug would make the Italian Amiga version of Future Wars not completable because the actions described in the bug report have to be taken to complete the game. But currently I can't reproduce the bug.

comment:4 by sev-, 12 years ago

We had similar bug with cracked English version with copy protection disabled.

Glorfindel, may you, please, provide md5s of all data files as well as the directory listing? Preferably put it as attachment here.

comment:5 by SF/glorifindel, 12 years ago

Here's my list of file: a7fcb61ad05a2ee8925c79997402742d *suite21.dat 52994ede72ce0608b4db821dc80585f0 *AUTO00.PRC 3f4934990d910a016a5db28aacdcfe0a *DELPHINE 1deac6c4702acaa2f522dd785aeefd30 *delphine.info f955de78916407eead1e2d3065335cec *dugger.dat 232a2fe6231573666f3a977f262495e9 *escalator ab4122f9499eda2ecbef4a6e4aca31c5 *fwars.dat acf971ed958d99e6a7e7f53a3176b2e4 *mediaval.dat 33b9a47db229dd5462ad7047779ed18c *moines.dat 08c3a432b85d72a101fafe660e6851b1 *PART01 2470976fb607b19c475a15a150ff1d19 *PART02 0f2a2c07ce9436678bc3c3aa06ecb5bf *PART03 9c1de0cf3097b86fdba5e96f4ebdd30d *PART04 0b38d1b096ffe629958804cc4254466d *PART04B 42588fd22ea3d1539c53f6fd477934d8 *aliens c5af74bfe633d5d4e43096b276c60ec7 *suite22.dat 36901fc8cdaf525910e645e3c7ab76d1 *suite23.dat 851bbac629680a61cf9a68002addcd90 *superfutur b7243a1d6f1c9740fcdd5bf18fec7caf *texte.dat

The source of this files should be the original floppy, but I can't be sure, as I ask the ebay seller from which I've bought them to copy the data to a CD, as I can't read them with my hardware. I deleted the files that were useless according to the datafile wiki page.

comment:6 by SF/buddha_, 12 years ago

Status: newpending

comment:7 by SF/buddha_, 12 years ago

Glorifindel, does this bug happen anymore? I'd like to know as I fixed the font loading which was throwing some Valgrind warnings so there is a possibility that that may have fixed this bug, but as I can not reproduce the bug myself, I do not know if it has gone.

comment:8 by SF/sf-robot, 12 years ago

This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).

comment:9 by SF/sf-robot, 12 years ago

Status: pendingclosed

comment:10 by SF/glorifindel, 12 years ago

Just tested this and can confirm that the bug is completely gone.

comment:11 by SF/glorifindel, 12 years ago

(Forgot to mention, I've used 0.13 stable version of ScummVM)

comment:12 by SF/buddha_, 12 years ago

As there have been very little changes made to the Cine engine after the 0.13.0 release I feel it is quite safe to venture that this bug is not present in the current trunk either (And to further clarify, I have never been able to reproduce this bug myself, so I really can't test it).

In the final analysis I think this was probably a question of trashed memory and either the Valgrinding and fixing of the previously memory trashing font loading did the trick or something else did. My vote is for the font loading fix (Revision 34065).

Closing as fixed.

comment:13 by SF/buddha_, 12 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.