Opened 12 years ago

Closed 11 years ago

Last modified 22 months ago

#3811 closed defect (worksforme)

WINCE: build does not run on CE 5.2 (WM 6.1)

Reported by: SF/raburton Owned by: SF/knakos
Priority: high Component: Port: WinCE
Keywords: Cc:
Game:

Description

v11.1 wince package will not run on windows mobile 6.1 (windows CE 5.2). It gives the error "scummvm is not a valid pocket pc application".

Older versions (v9.1 & v10.0) will run just fine. So I suspect this regression comes from a duff compiler (according to the wiki cegcc was used for v11, but v9/10 were Visual Studio / VLC GCC).

Ticket imported from: #2017765. Ticket imported from: bugs/3811.

Change History (11)

comment:1 by SF/mac_es, 12 years ago

My own build, whith cegcc under MINGW/MSYS works prefectly in a Trinity whith WM 6.1, maybe the exe is too big for your device?

comment:2 by SF/raburton, 12 years ago

Interesting. v11.1 is actually slightly smaller than v10.0 which works fine. I've also tried someone in the forums plugin build which has a small exe, and tried compressing the official build with upx (goes down to just a couple of mb). No joy.

comment:3 by SF/mac_es, 12 years ago

Here you have a 0.11.1 compiled by me http://rapidshare.com/files/130061723/scummvm_ce_0.11.1.tar.gz.html

It is the branch whithout a patch. It is compiled whith cegcc in MSYS/MINGW, this is working for you?

comment:4 by SF/raburton, 12 years ago

Nope, that doesn't run either, same error.

I tried building my own with vlc gcc, but after a very long time of hacking the compiler around to build I couldn't get scummvm itself to build. I guess too much has changed since the last version to use vlc gcc.

comment:5 by fingolfin, 12 years ago

Owner: set to SF/knakos
Summary: WinCE build does not run on CE 5.2 (WM 6.1)WINCE: build does not run on CE 5.2 (WM 6.1)

comment:6 by fingolfin, 12 years ago

Priority: normalhigh

comment:7 by fingolfin, 12 years ago

What is the status of this item?

comment:8 by SF/raburton, 12 years ago

Lost interest. Left the bug open for anyone else that may be having the same problem, I can't be the only person. However no one else has joined the ticket to say they get it too so feel free to close it if you want to tidy up.

Richard.

comment:9 by SF/knakos, 11 years ago

Resolution: worksforme
Status: newclosed

comment:10 by SF/knakos, 11 years ago

I have reports of scummvm running fine on WM6.1.

Thanks for the report.

comment:11 by digitall, 22 months ago

Component: --Unset--Port: WinCE
Note: See TracTickets for help on using tickets.